Go Down

Topic: problema con lcd arduino uno (Read 1 time) previous topic - next topic

mikele469

salve a tutti ragazzi spero che qualcuno di voi riesce a capire cosa sta succedendo al mio arduino in poche parole ho cablato un display lcd 16x2 al mio arduino uno e una shield a due relè che mi va a eccitare un contattore a 220 volt.finchè il mio arduino è a riposo sul displey compaiono le scritte di defolt ma quando vado ad eccitare il relè il display impazzisce scrive aramaico e non si capisce piu niente premetto che questo mi succede solo se alimento il mio arduino con alimentatore perchè se viene alimentato da usb funziona tutto tranquillamente quale puo essere il problema???
spero che qualcuno riesca ad aiutarmi...ringrazio anticipatamente :)

pelletta

L'alimentatore in questione stava dentro un uovo di pasqua per caso?
Battutina a parte, verifica che eroga abbastanza corrente per reggere tutto il circuito; posta anche i dati dell'alimentatore e lo schema elettrico magari c'è qualcosa che non va.

mikele469

allora l'alimentatore me lo hanno dato insieme ad arduino quando lo ho acquistato cmq è un 12volt 330ma ora quello che non capisco tu mi dici che non basta l'alimentazione ma in realtà l'usb del pc eroga solo 5 volt quindi perchè dobvrebbe comportarsi cosi???

pelletta

330mA sono un pò pochini, la usb ad esempio eroga 500mA.
Riesci a vedere quanta corrente richiede tutto il circuito?

mikele469

bhe il relè assorbe circa 180 ma in 5 volt il display non so quanto puo assorbire

pelletta

Alcuni display lcd possono chiedere anche più di 100mA, non è tanto la parte logica ma la retroilluminazione che va a incidere sul consumo.
Stai dicendo che il relè da solo consuma 180mA e ne hai due, già se li attivi tutti e due sei fuori specifiche.
Devi contare anche l'assorbimento dell'arduino e di tutti gli altri componenti.
Come primo tentativo prova a usare un altro alimentatore più performante, diciamo che da 1 Ampere basta per fare le prove.

Controlla sempre la polarità del connettore prima di collegarlo sull'arduino, se è invertita potresti fare dei danni.

mikele469

ho gia provato con un alimentatore da 12 1 A ma il risultato non cambia potrebbe essere un problema di massa che mi causa questo???ho pensato il pc la sua usb ce l'ha collegata sicuramente a massa mentre l'alimentatore non ha una massa credo(spero di non dire chiacchiere)

mikele469

nessuno riesce ad aiutarmi ragazzi??? =(

BrainBooster

Dovresti postare anche i collegamenti.... cos'hai collegato sul pin Vin?

gpb01


ho gia provato con un alimentatore da 12 1 A ma il risultato non cambia potrebbe essere un problema di massa che mi causa questo???ho pensato il pc la sua usb ce l'ha collegata sicuramente a massa mentre l'alimentatore non ha una massa credo(spero di non dire chiacchiere)


Come sarebbe che l'alimentatore "non ha una massa" ???  Scusa ma il "negativo" dell'alimentatore non l'hai collegato al GND ??? Come hai fatto i collegamenti ???

Guglielmo
Search is Your friend ... or I am Your enemy !

Michele Menniti

beh, l'ha detto lui che temeva di dire "chiacchiere", le ha dette :D Ovvio che se non avesse collegato il negativo non vedrebbe nulla. A mio parere il problema deriva dal contatto sulla 220V che fa rientrare qualcosa tramite alimentazione; infatti l'alimentatore esterno è collegato direttamente alla 220V mentre l'USB è molto ben isolata; fermo restando che bisognerebbe capire se poi l'alimentatore da 1A non sia una ciofeca, quindi sarebbe utile misurare la tensione di 5V quando scattano i relé. Ma siamo sicuri poi che quei relé supportino 220V sui contatti? la maggior parte dei casi quelle scheda sono realizzate con relé che operano max a 110Vac.
Comunque sia concordo sul fatto che serve necessariamente uno schema elettrico per verificare i collegamenti.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

gpb01


..... Ma siamo sicuri poi che quei relé supportino 220V sui contatti? la maggior parte dei casi quelle scheda sono realizzate con relé che operano max a 110Vac.
Comunque sia concordo sul fatto che serve necessariamente uno schema elettrico per verificare i collegamenti.


... e, a questo punto allora, se, oltre allo schema, posta anche una foto dei relé dove si leggono le specifiche è ancora meglio ;)

Guglielmo
Search is Your friend ... or I am Your enemy !

Michele Menniti



..... Ma siamo sicuri poi che quei relé supportino 220V sui contatti? la maggior parte dei casi quelle scheda sono realizzate con relé che operano max a 110Vac.
Comunque sia concordo sul fatto che serve necessariamente uno schema elettrico per verificare i collegamenti.


... e, a questo punto allora, se, oltre allo schema, posta anche una foto dei relé dove si leggono le specifiche è ancora meglio ;)

Guglielmo

+1  :)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

mikele469

allora signori i relè sono a 250vac 10A quindi supportano tranquillamente la corrente normale di casa ho notato pero che se non alimento il contattore che si trova dopo il rele il problema del display non c'è piu quindi posso escludere il contattore e lasciare solo il relè?

gpb01

... vedi perché ti si chiedono schemi e foto ... che diavolo è il "il contattore che si trova dopo il relé" ??????  

Mi ricordi un noto "barone di Fisica" a cui, in una conferenza, chiesero "... quanto doveva essere arricchito l'Uranio per ottenere certi risultati" e lui rispose candidamente "... bé ... un po' "  :smiley-eek: :smiley-eek: :smiley-eek:

Guglielmo
Search is Your friend ... or I am Your enemy !

Go Up