Pages: [1]   Go Down
Author Topic: DFROBOT MIDISHIELD  (Read 423 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello

  smiley

I have a arduino uno and a DFROBOT midi shield. I and I'm using it as a midi controller.
it works as long as I use a USB cable to my computer but it won't run on a 9V battery.
I have the battery connected to the uno on the bottom (direct 9V) it powers the uno but not the DFROBOT midi shield.
« Last Edit: April 20, 2013, 05:31:58 pm by Trazman001 » Logged

Brisbane, Australia
Offline Offline
Edison Member
*
Karma: 33
Posts: 1123
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That really sounds quite odd.  The 9V passes through a linear regulator on the Uno then the regulated 5V from that goes through a switch that automatically selects the regulated power in preference to the USB if both are present, or the USB only if there's no regulated source.  If the 9V powers the Uno then you'd presume all that is functioning correctly.  Downstream of that switch circuit it's just the 5V rail so there's no difference between both circuits.  If there is power present either should get to your shield.

Looking at the board layout of the DFRobot MIDI shield I don't see a power LED (but then could have overlooked it).  How are you confirming there's no power to the shield when it's not functioning?

Geoff
Logged

"There is no problem so bad you can't make it worse"
- retired astronaut Chris Hadfield

Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

the uno turns on but the midi shield is not sending midi I can confirm this. I have a USB to midi cable.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 44
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Does this have anything to do with the midi board or the uno? Or is it just with the arduino pro?

Quote
Note: When using this shield with the Arduino Pro you will have to bypass the TX/RX resistors on the Pro to get enough current to the shield.
Logged

Pages: [1]   Go Up
Jump to: