Go Down

Topic: AIUTO-Arduino non fornisce 5v (Read 435 times) previous topic - next topic

Goa1

Salve a tutti, sto progettando un circuito per gestire dei LED RGB saldati su PCB con Arduino UNO, o meglio 16 LED gestiti a matrice (ovvero i 16 pin '+' di uno stesso colore sono divisi in 4 righe e i 16 pin '-' in 4 colonne); perciò alimentando una delle 4 righe di un colore (cioè uno dei 4 gruppi di LED) e attivando uno dei 4 neutri si accende un determinato colore di un led. Il controllo dei neutri l'ho sviluppato attravero un transistor NPN BC547B, e funziona, cioè il LED si accende, il problema è un altro: al LED arrivano pochi volt e la luce è debole! Facendo qualche test mi sono accorto che in pratica sulla resistenza di limitazione collegata al pin '+' di un colore quando Arduino porta il rispettivo pin allo stato HIGH invece che darmi 5 volt me ne da 2,45.
Ho provato a collegare Arduino con gli stessi pin ad un altro LED su breadboard senza transistor e il pin fornisce 5 volt;  se collego un pin '+' di un colore e il neutro di una colonna direttamente ai pin 5V e GND i led sulla PCB si accendono perfettamente!
Qualcuno ha qualche suggerimento per favore? Potrebbe essere dovuto ai transistor NPN?
Grazie in anticipo  :smiley-sweat:

PaoloP

Scheda 9 --> http://arduino.cc/forum/index.php/topic,146152.0.html

uwefed

Non ho capito il circuito.
Potresti farne uno schemino (anche solo disegnato a mano e fotografato)?
Ciao Uwe

leo72

Scusa ma 16 led RGB sono 48 anodi, ogni led RGB ha 3 canali.

FràFrà

Puo essere che come amperaggio non rientri e quindi hai il calo di tensione?

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy