Pages: [1]   Go Down
Author Topic: [OSX] JY-MCU Bluetooth Module issues  (Read 1444 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I'm fiddling around with some now modules I just got. One of them is the JY-MCU Bluetooth Module V1.05, which I ordered from dx - I thought that it would be quite a simple task to get it to run, as so many before me.

I'm using the Arduino Leonardo board, and I'm coding on a mac with Mac OSX 10.8.3.

The BT-Module is connected like this:
    Arduino RX1 -> JY-MCU TXD
    Arduino TX1 -> JY-MCU RXD
    Arduino 5V -> JY-MCU VCC
    Arduino GND -> JY-MCU GND

On the back it says Power 3.6-6V, so I figured 5V would be okay (I've tried both with 3.3V and 5V, without any results whatsoever)

I'm able to connect to the BT module to my mac just fine, the red LED on the module goes to solid, so I know it's connected.
The issue is however, I can't listen to the output of the module.
I have written this program just to test if I could listen in on the serial:
Code:
int number = 1;

void setup() {
  // put your setup code here, to run once:
  Serial.begin(9600);
}

void loop() {
  // put your main code here, to run repeatedly:
  Serial.print("Loop nr: ");
  Serial.print(number++);
  Serial.println("");
  delay(1000);
}

I uploaded this using the USB cable and I can read the output of the Arduino just fine, when I listen to the USB port. When I then try to switch to Serial Port -> /dev/tty.linvor the light on the module becomes solid, but nothing happens in the terminal. I have been using both the Arduino software and CoolTerm to try to listen to the bluetooth port.
I have tried to follow http://arduino.cc/en/Reference/serial which says that everywhere I wrote Serial above should be replaced with Serial1, but alas, same result... None..

I've really tried to get my head around this, but I can't get the module to recieve or respond

I hope there's somebody out there with the know-how, so I can feel stupid for the rest of the week smiley-wink

Regards
/Claus
Logged

Dee Why NSW
Offline Offline
Edison Member
*
Karma: 47
Posts: 2166
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There is nothing wrong with your code, and the light action suggests that there is nothing wrong with the bluetooth module either. This implies your problem is at the other end.

Right now, I am running your code and can see it on my desktop via cable and laptop via bluetooth.

The bluetooth module uses the same bus, hence the same code , as the USB serial. You could have conflict if you are using the USB cable for power and you need another power source - or listen somewhere else.

ed.
Is the terminal programme running at 9600?
« Last Edit: April 23, 2013, 07:35:50 pm by Nick_Pyner » Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I think that on the Leonardo TX1 and RX1 should be addressed using Serial1, not Serial (which is for the Usb port).
Logged

Dee Why NSW
Offline Offline
Edison Member
*
Karma: 47
Posts: 2166
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I think that on the Leonardo TX1 and RX1 should be addressed using Serial1, not Serial

Aha! I didn't realise that. I tried his stuff on an EtherTen, and it worked as well as it looked.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey again guys... I don't know why it didn't work yesterday - But it works now with the Serial1 usage (Which I already did try).
My problem might've been that I tried to upload it via the port /dev/tty.linvor.

Thanks for the help smiley
Logged

Pages: [1]   Go Up
Jump to: