Pages: [1]   Go Down
Author Topic: Problema con sensor fotoelectrico  (Read 1037 times)
0 Members and 1 Guest are viewing this topic.
Mexico
Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola que tal primero que nada soy principiante en este foro y de igual manera soy principiante en el ambiente de arduino, llevo días desarrollando un contador de bultos de azúcar para la empresa en la que trabajo y ando con pruebas, el programa funciona así:

Por un cable mando 5 volts al común de unos sensores fotoeléctricos, y otro cable lo conecto al estado abierto, entonces cuando se interrumpe la señal entre sensores se cierra y salen cinco volts de regreso, cable que tengo conectado a un pin del atmega328, cuento el tiempo que dura en high el pin y en función de un tiempo mínimo o un tiempo máximo determino si es un conteo bueno o conteo malo.

Un bulto de azucar tarda en pasar de entre 1100 a 1300 ms, el problema esta en que se me regresan rebotes por el cable, generando malos conteos, tratando de evitar eso le meti una validacion de que si el conteo es menor a 75 ms no lo tome en cuenta pensando que es un rebote de los sensores, pero de igual modo mal con las cuentas.

Alguna duda sobre que pudiera estar pasando?
Pensando en el haz de luz de los sensores los incline para que sensaran el bulto de manera transversal, siguio igual, pensando en que el movimiento de la banda se transmitiera a los sensores los fije a la pared e igual.

He estado pensando mejor en poner un sensor ultrasonico, que me recomiendan
Logged

Miami/Florida
Offline Offline
Sr. Member
****
Karma: 14
Posts: 342
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

1- Si el tiempo que demora en pasar el azucar es entre 1100 y 1300 ms. Por que pones el limite de tiempo minimo en 75ms?. Pienso debes ponerlo en 1000 por lo menos. Con eso puedes reducir la cantidad de lectureas erroneas.

2-En estado estacionario, prueba si al poner el azucar o el bulbo o lo que sea que quieres detectar se interrumpe la luz y aparece el cambio de voltage adecuado en el pin del Arduino. Deslizas el bulbo de lado a lado o como este configurado y ves si el voltage cambia.

3-Pudiera suceder que la variacion en la intensidad de luz no sea suficiente para provocar un cambio de voltage en el sensor completamente digital, es decir aunque el voltage varie, el cambio no llega a se interpetado como un cambio de "1" a "0" o viceversa (depende de como lo hayas hecho). Eso me parece bastante probable porque el azucar es semitransparente y quizas no produzca suficiente "swing" en le voltage de salida del sensor.

4- Si tu bulbo (que no se lo que es) es cilindrico y el paso por el sensor es transversal entonces como varia la seccion transversal varia la cantidad de luz que logra pasar. Esto en combinacion con lo anterior (#3) puede provocar que el tiempo detectado como obstruction de la luz, sea mas pequeno que el que tarda todo el cilindro en pasar frente al sensor.

5-Prueba con un voltimetro u osciloscopio como varia el voltage a la salida del sensor a medida que pasas el bulbo frente a este. Creo que asi notaras lo que esta sucediendo en realidad y por que no te funciona.

Si no encuentras el problema muestra esquemas, fotos y codigo aqui para comprender mejor y poder ayudarte.

Buena suerte.
Logged

Perseverance is 90% of the solution. The remaining 10% is more perseverance.

Mexico
Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Primero, gracias por su pronta respuesta, probare con las opciones que me has dado y checare resultados, y probare moviendo los sensores pensando en lo que comentas sobre la luz referente al azucar, otra opcion seria probar con un sensor ultrasonico acabo de comprar uno para pruebas, pero bueno gracias por tus comentarios voy a tomarle fotos a las conexiones y las voy a postear asi como el codigo.
Logged

Miami/Florida
Offline Offline
Sr. Member
****
Karma: 14
Posts: 342
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Otro problema podria ser si no estas usando sensors infrared que la luz ambiente este interfiriendo.
Si el bulbo de azucar es reflectivo entonces puedes colocar una placa oscura detras para que nbo refleje la luz y detectas entonces la refleccion del bulbo sin necesidad de pasar la luz a traves de este. Lo principal es que tienes que determiner cual es el umbral de deteccion en cualquier caso.

Si, el sensor ultrasonico es otra variante anuque la capacidad de resolucion puede ser un problema si los bulbos pasan muy unidos unos a otros frente al sensor.
Logged

Perseverance is 90% of the solution. The remaining 10% is more perseverance.

Mexico
Offline Offline
Newbie
*
Karma: 0
Posts: 18
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Estoy utilizando este sensor, OMRON E3JK, a lo mejor pudiera ser que el objeto no estan opaco como para poder obstruir la luz, en fin ahora sobre lo que me comentas del sensor que perderia utilidad en caso de la cercania entre objetos, hay en promedio entre 3 y 5 segundos de separacion por objeto al pasar por la banda, no creo que eso me pudiera afectar, pero bueno el fin de esto es hacer pruebas para ir afinando detalles y dejar la mejor solucion.
Logged

Miami/Florida
Offline Offline
Sr. Member
****
Karma: 14
Posts: 342
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
hay en promedio entre 3 y 5 segundos de separacion por objeto al pasar por la banda, no creo que eso me pudiera afectar

El tiempo no es lo importante, sino la separacion (distancia fisica entre los elementos); pues el haz ultrasonico tiene un patron de radiacion que es un abanico (en angulo) y si los objetos estan alejados entonces el haz hits 2 objetcts al mismo tiempo y no puede discernir.
Logged

Perseverance is 90% of the solution. The remaining 10% is more perseverance.

Pages: [1]   Go Up
Jump to: