Go Down

Topic: [SOLVED] Sketch upload failed after (maybe) shorting pins to 12VDC (Read 596 times) previous topic - next topic


Hello People,

I recently got in to Arduino and thought I'd share one of the problems and solutions I've come across.

I was using my Uno to drive a small motor (+12V supply with L293D) and take in a couple of button inputs when I must have shorted some pins (maybe +12V) to Digital 1 pin (Tx) because I could no longer upload sketches. I tried swapping the 328p but that did not fix it. I tried rewriting the firmware to the 16U2 but that also did nothing. Then I started to investigate with a scope and found that the Tx signal coming from the 328p looked good on the its side of RN4A ( full +5 to 0V swing) but not on the 16U2 side (+5 to +4.6V swing). I'm assuming I somehow half fried the input on the 16U2 causing it to pull the line high all the time. I figured the only way to fix this was to replace the 16U2 but I don't have the tools to do that so I thought up a different fix. I needed to eliminate the voltage drop across RN4A so I soldered a short across it. I know that this resistor is put there for some sort of protection or buffering but I don't care. I'll take the risk to get my board back up and running. With the resistor shorted I can again upload sketches to my Uno. Because of this mod i'm going to try and avoid using pin 3 (tx or Digital 1) of the 328p in my projects with this board.

I hope this helps someone at some point. I know I couldn't find much to help me after I tried the chip swap and firmware rewrite.

If there's a better solution to this problem please let me know. I don't mind the jumper but it'd be nice to fix it properly.


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131