Go Down

Topic: Deek robot SD shield (Read 10515 times) previous topic - next topic


I bought a cheap generic SD card shield from EBay (branded as Deek Robot). I can't get the thing to work. I've tried the Cardinfo in the examples section, and I get the mesage
Code: [Select]
"Initialization failed. Things to check:
    is a card is inserted?
     Is your wiring correct?
    did you change the chipSelect pin to match your shield or module?"

There is a card inserted (I've tried a few different SD cards, my laptop reads them all fine).
I haven't done any custom wiring, I've just popped the SD shield on top of my Leonardo, so I assume that's correct.
I don't know what value to set chipSelect to. I've tried  4, 10, 8 and 12. The SD shield came with no information at all. It has Deek-Robot branding on it. I've looked on the www.deek-robot.com website and there's no information about this board on there. I've contacted the EBay seller but they don't have a great command of English and seem utterly baffled by the whole concept of documentation and don't seem to understand that I'm asking for information on how to use the device. They've offered to send a replacement in case this one was damaged in transit, which is nice, but I don't really think it is damaged, it doesn't look it, the Power LED comes on and the card slots in securely. What I really want is some information on how to use the device, but the seller appears to know nothing about this. Has anyone used one of these Deek Robot boards successfully and can you let met know what you did?


You could check out this site:


They are official importer for Switzerland and have added documentation.

This is how I got the SD datalogger shield to work. It interfered with my standard LCD display shield on top and I switched my pins from 8-9-4-5-6-7 to 2-3-4-5-6-7 with the LCD connected. LCD is DFRobot.

The SS pin is 10

I used the UNO


Cheers for the reply, but it does appear that this board is dead :( I tried the RTC example from the play-zone site and after a bit of phaff getting  it to compile with the Time.h library it seemed to compile and upload OK, but I just get the error
Code: [Select]
DS1307 read error!  Please check the circuitry. I had tried the ChipSelect set to 10 and it still can't initialise the SD card.
I'm chucking  this DEEK robot card in the bin and I've just ordered an Adafruit one.


I received one by mail today.

I tried following the instructions at Adafruit, but only got a garbled reply from the RTC.
I used the DS1307-example from "RTClib.h"
(I think it is a baud rate problem)

https://www.pjrc.com/teensy/td_libs_DS1307RTC.html and https://www.pjrc.com/teensy/td_libs_Time.html have so far made me able to receive a time from the RTC.
DS1307RTC Read Test
Ok, Time = 21:50:14, Date (D/M/Y) = 21/10/2014
Ok, Time = 21:50:15, Date (D/M/Y) = 21/10/2014
Ok, Time = 21:50:16, Date (D/M/Y) = 21/10/2014
Ok, Time = 21:50:17, Date (D/M/Y) = 21/10/2014
I can see the cardinfo with the cardinfo example in the SD library..... but I have to go get a new one tomorrow. I only had an old FAT12 formatted 32 Mb card in the drawer.

"Nothing is foolproof to a sufficiently talented fool"


did you get it running already ?
I'd be interested in a solution because I was only able to run the RTC part of the board. However, no success with the SD Card.


Can't get this deek-robot shield running :( i pop it on an arduino mega and none of the examples work. do i have to solder any extra stuff?


Can't get this deek-robot shield running :( i pop it on an arduino mega and none of the examples work. do i have to solder any extra stuff?
No, there should be no soldering of any parts.
I sent mine back to the supplier and await what I will get back. I suspect malfunction. But we will see ...
If it is still not working those shields are for trash.
I'll keep you informed.


I am using the Deek Robot shield on a UNO combined with a Funduino LCD I2C display
and an adafruit ADS1115 16Bit ADC - all working fine.

The SD card uses the SPI bus - so it needs addressing.
The Deek robot seems to use as follows:
D10 - Chip Select

Don't use these GPIO pins for anything else.

Remember to install the RTC library from Adafruit (compatible)

Also install the SD library from Grieman (much better than the built in)

Set your includes as follows:

Code: [Select]
#include <SPI.h>
/*ensure to install the SdFat Library from:
//#include <SD.h>    //Loose this in favour of SdFat Library for timestamp
#include <SdFat.h>   //New SdFat library
SdFat SD;            //Add this line for backwards compatability with coding
#include <Wire.h>
#include <RTClib.h>

Code: [Select]
// We are using Adafruit clone - so chipSelect = 10
const int chipSelect = 10;
// and the RTC type is RTC_DS1307

Works for me - might work for you.


Edit - Note for Mega users!

The Mega does not use the same SPI pins as an UNO.

See the Adafruit documentation here: https://learn.adafruit.com/downloads/pdf/adafruit-data-logger-shield.pdf

Page 30 shows how to use a modified library to be able to show the Mega which pins to use on the shield.


Works for me - might work for you.

This worked for me on a 'Deek-Robot Data logging shield v1.0' on a Uno R3.



I purchased one of these on Amazon and my first warning should have been that I received 2. Neither worked with an Uno or Mega2560, the power led didnt even light up. AgeBee, what ended up happening ?


HI! I bought some DEEK-ROBOT Data logging shields V1.0 and want to use them with Arduino Mega 2560 R3.
(just the  the SD-sheeld on top of the Mega).
The clock is working but not the SD.
Many Thanks, If I get a real working scetch.


You will have to rewire the SPI bus (disconnect from 13/12/11 by cutting the traces and connect to 50/51/53 or better to the ICSP that carries the correct signals too, a 3x2 socket soldered facing down in the correct position works well), or use soft-SPI for the SD card (I do not know how).
Ah, this is obviously some strange usage of the word 'safe' that I wasn't previously aware of. (D.Adams)


Related to the RTC, for use on a Mega; I made the cuts provided for A4 and A5 and then added wires to the Mega SCL and SDA. Of the 3 SC shields, one had a battery socket not soldered.
Related to the SD; I use the SDFat library. There is an example, ThreeCards which supports software SPI and it works. No cuts/jumpers needed.
Overall, initially I had intermittent operation of the RTC and SD on all cards. After a few physical removal/install of the shields, they worked. I'm attributing it to contamination on the pins which happens after PCB cleaning and general storage oxidation. 

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131