Go Down

Topic: Avoid visible flickering when dimming LEDs with PWM (Read 589 times) previous topic - next topic

Grifone

Hello to everyone, i'm new to this forum so i hope i'm posting in the correct section.
I've a problem on dimming LEDs with Arduino Uno PWM pins. I have connected 3 PWM to 3 TIP120 transistors to dim 3 different 12 Volts LED stripes, but when dimming the Stripes visibly flicker. Why do I have this behavior? And how i can overcome it?
I've used as 12 V power supply three different sources: a 12V stabilized power supply, a 12 V DC adapter (12,8 V measured) and a 12 V DC adapter (18 V measured with a tester) all taken from old electronic stuff, and i saw flickering in the first two power supplies.

Thanks in advance.

MAS3

Hi Grifone, and welcome.

What LED stripes are that ?
Are the supplies powerful enough to handle those LEDs ?
Is the flickering always present, or at some PWM value ?
Given the not stabilized adapter has no flickering, that may be more powerful than the other ones.
Did you use any resistors, and if so what value are they and why did you choose those.
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Grifone

Hi MAS and thanks for the reply. All the supplies i used are powerful enough to my stripes, and the flickering is more present at low PWM value (i.e. lower LED light). I use the classical LED stripes with 60 5630 LED/m.

Paul__B


Did you use any resistors, and if so what value are they and why did you choose those.


So?  What is the answer?

Perhaps you need to illustrate your actual circuit, and - post the code you are using.

CrossRoads

PWM is 490 Hz, how can that be seen to be flickering? Very odd.
Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

TomGeorge

Hi, can you please post a picture of your project and a CAD or picture of your circuit diagram please.
Also post your sketch. use code tags.
Code: [Select]

Have you  got the led's assembled on a protoboard,the strip conductors can be a problem with high current use.
Its sounds like your power supplies for the LED does not have  enough filtering or regulation.

Can you measure the LED supply voltage for us, one with the LEDs flickering and one with them not, ie higher duty cycle, thanks.

You have asked us for help, its your project so you are miles ahead with understanding how its assembled. Pictures will help us get up to speed without misguided advice.

Tom...... :)
Everything runs on smoke, let the smoke out, it stops running......VK3DMK

Go Up