Go Down

Topic: lm35 problemi connessione (Read 383 times) previous topic - next topic

ciao a tutti..volevo chiedervi una cosa.ho preso un sensore lm35 e l'ho collegato ad arduino.Ho collegato il primo piedino a sx del sensore a 5 volt,l'ultimo piedino a massa e il piedino intermedio l'ho collegato a pin analogico a0. Lo skecth che ho utilizzato è il seguente:

//declare variables
float tempC;
int tempPin = 0;

void setup()
{
Serial.begin(9600); //opens serial port, sets data rate to 9600 bps
}

void loop()
{
tempC = analogRead(tempPin);           //read the value from the sensor
tempC = (5.0 * tempC * 100.0)/1024.0;  //convert the analog data to temperature
Serial.print((byte)tempC);             //send the data to the computer
delay(1000);                           //wait one second before sending new data
}

il mio problema è che il sensore mi restiruisce sulla seriale sempre 20° anche se tocco per qualche minuto il sensore con le dita,anzi a volte diminuisci la temperatura.C'è qualcosa che sbaglio nel collegamento?vi ringrazio anticipatamente

Erdin

http://learn.adafruit.com/tmp36-temperature-sensor

Hello gianni1989,

my italian is so bad that I have to reply in english.

You can also have a look at:

http://heliosoph.mit-links.info/connecting-an-arduino-with-a-lm35-temperature-sensor-special-issues/

Very best regards

Elektrix
My blog about arduino and Linux themes:
http://heliosoph.mit-links.info/

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy