Pages: [1]   Go Down
Author Topic: lm35 problemi connessione  (Read 296 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao a tutti..volevo chiedervi una cosa.ho preso un sensore lm35 e l'ho collegato ad arduino.Ho collegato il primo piedino a sx del sensore a 5 volt,l'ultimo piedino a massa e il piedino intermedio l'ho collegato a pin analogico a0. Lo skecth che ho utilizzato è il seguente:

//declare variables
float tempC;
int tempPin = 0;

void setup()
{
Serial.begin(9600); //opens serial port, sets data rate to 9600 bps
}

void loop()
{
tempC = analogRead(tempPin);           //read the value from the sensor
tempC = (5.0 * tempC * 100.0)/1024.0;  //convert the analog data to temperature
Serial.print((byte)tempC);             //send the data to the computer
delay(1000);                           //wait one second before sending new data
}

il mio problema è che il sensore mi restiruisce sulla seriale sempre 20° anche se tocco per qualche minuto il sensore con le dita,anzi a volte diminuisci la temperatura.C'è qualcosa che sbaglio nel collegamento?vi ringrazio anticipatamente
Logged

Offline Offline
Edison Member
*
Karma: 57
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

http://learn.adafruit.com/tmp36-temperature-sensor
Logged

Germany
Offline Offline
Full Member
***
Karma: 1
Posts: 141
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello gianni1989,

my italian is so bad that I have to reply in english.

You can also have a look at:

http://heliosoph.mit-links.info/connecting-an-arduino-with-a-lm35-temperature-sensor-special-issues/

Very best regards

Elektrix
Logged

My blog about arduino and Linux themes:
http://heliosoph.mit-links.info/

Pages: [1]   Go Up
Jump to: