Go Down

Topic: calcul d'amplification avec un transistor (Read 1 time) previous topic - next topic

atlas2003

Bonjour

Dans une autre vie, j'étais étudiant en BAC STI electrotech.
J'etais capable de calculer pas mal de chose grace a mes cours de physique et d'électricité/electronique

Malheuresement, plus de 15ans ont passé et fatalement, j'ai tout oublié..

Est ce que l'un d'entre vous pourrais m'aider pour ceci:

J'utilise un arduino comme telecommande infrarouge pour un projet.
La diode IR a besoin de 100ma, courant que l'arduino n'est pas capable de fournir. Je pourrais utiliser un transistor en mode amplification, mais je ne me souviens pas du tout comment calculer cela. J'ai regarder sur d'autres sites externe, mais j'ai quand même du mal.

Par exemple, chez moi, j'ai plein de 2N222.
Qu'elle courant traverserait ma diode si j'utilisais ce transistor?

MrPoulet

Tu vas utiliser ton transistor en saturé.
Et tu vas devoir mettre une résistance pour fixer le courant que tu veux.

MrPoulet



Tu dois calculer la tension au borne de R1
Donc tu fais une loi des mail: UR1 = Vcc - Vce_sat - Vd1         (Vd1= la tension au born de ta LED)
Maintenant que tu as ta tension à R1 tu peux choisir sa valeur grâce à une loi d'ohm:
UR1 = R1               (I = les 100mA)
I

MrPoulet

Oups j'ai mis deux R1, je parle de celle en série avec la LED.
(Ne tiens pas compte des 10K indiqué sous les reistances)

patg_

Pour un tel montage on est plutôt en émetteur commun, non? (émetteur à la masse et charge entre VCC et le collecteur).
Pour R1 en effet c'est comme indiqué mais pour la résistance de base, tu comptes une tension base-émetteur de 0.6v et un courant de disons 5 mA. Avec un gain d'environ 100 pour un 2N2222 si j'ai bonne mémoire, t'as ainsi un peu de marge pour t'assurer qu'il est bien saturé.

MrPoulet

Je t'avoue que j'ai toujours mis en émetteur commun pour ce genre de montage.
Qu'il soit en EC ou en CC, change quelque chose si on utilise le transistor en amplificateur linéaire, non ?
(J'ai un doute j'essaie de trouver une réponse.)

atlas2003

Merci pour vos réponses

Je vous lis avec intéret :)

68tjs

Il faut bien poser les conditions de fonctionnement de ce que tu cherches à faire avant de partir sur un schéma.
De qu'elle tension dispose tu pour alimenter ta diode : 5 V, 9 V, 12 V ou autre ?
Le courant qui doit passer dans la diode doit-il faire 100mA +/- 5% ou "environ" 100mA ?
Selon le cas le schéma peut ne pas être le même.

En pj les différents schémas possibles.
Le plus courant, parce que le plus simple, est le montage avec un NPN câblé en émetteur commun.
Les montages en collecteur commun ont une bande passante plus élevée que celle d'un émetteur commun mais n'ont pas de gain en tension, juste en courant.

Les montages en source de courant sont "luxueux" mais utiles à connaître car dans certaines applications ils peuvent être nécessaires.
Pour te rappeler tes cours sur le calcul d'une résistance de base :
http://arduino.cc/forum/index.php/topic,100727.msg756494.html#msg756494

fdufnews

#8
Apr 30, 2013, 10:13 pm Last Edit: Apr 30, 2013, 10:18 pm by fdufnews Reason: 1

Je t'avoue que j'ai toujours mis en émetteur commun pour ce genre de montage.
Qu'il soit en EC ou en CC, change quelque chose si on utilise le transistor en amplificateur linéaire, non ?
(J'ai un doute j'essaie de trouver une réponse.)



Le problème en collecteur commun c'est qu'il faut une tension plus élevée pour saturer le transistor. En fait en mode saturé/bloqué la tension sur la base doit quasiment être la même que celle au collecteur. Ce qui n'est pas évident à obtenir dans la mesure ou les sorties logiques ne sortent pas toujours un niveau 1 égale à la tension d'alimentation. C'est pourquoi le montage émetteur commun est préféré.

atlas2003

Ok, oui j'aurais du vous donner plus d'info

La led infrarouge en question est celle ci:
http://www.taydaelectronics.com/datasheets/A-1544.pdf
Pour le 100ma, je le vois dans le datasheet... Est ce que "environ" 100ma suffit? j'imagine que oui? Peut etre pas besoin d'etre +/- 5%. (a moi que vous me dites le contraire)

Mon arduino est alimenté en 3.3v seulement et non en 5v.

Merci!


MrPoulet


Go Up