Go Down

Topic: Uno SMD r3 arrived in DFU, installed FW & bootloader, now 'out of sync' (Read 2 times) previous topic - next topic

NotSoBright

I spent a long time reading through this forum and resetting everything only to find out the manufacturer installed the wrong program on my board. Admission of guilt found here ---- http://osepp.com/learning-centre/start-here/uno-r3-plus/ I don't know if it will help with authentic arduino boards (never had a problem with mine) but loading under the other board types worked for me. I just went down the list until I found the one that worked "Due 328" will load my sketches on my labeled UNO R3 board. Shame on you OSEPP. You get what you pay for!!!!

pharmachris

Thanks for your time, you have been really helpful this whole thread, I do appreciate it!
I have contacted RS-online and they are shipping a new board out to me and don't need the old one back.
I think I'll try writing sketches straight to the chip using either ArduinoISP or an ICSP cable I am yet to build (I ordered a PCIe parallel port for $4 and found the tutorial for the cable) to use if I ever decide to make a project a permanent product. On that note could someone direct me to a tutorial on the process of getting a sketch running with no boot loader, specifically what if any changes do I need to make to my code?

Thanks again everyone for all the help

James C4S

Personally, I think you've spent too much effort at this point.  RS is an authorized distributor and authorized distributors are required to accept returns.  Time to try a new board.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

pharmachris

#13
May 06, 2013, 01:36 pm Last Edit: May 06, 2013, 02:48 pm by pharmachris Reason: 1
I have tried to burn the uno bootloader a number of times. All apparently successful (no error LED, heartbeat LED ok, everything fine) but it didnt make any difference.

However I was just reading another similar thread here and saw James C4S talk more of knock off boards being Duemilanove and in combination with his suggestion above (of trying different selection under board type), I decided to burn the Duemilanove bootloader.
That definitely made a difference. The pin 13 led now flashes slowly, longer off than on, but still within 1-2 second cycle. I guess that shows my bootloader burning is working, and from above, my loopback is working, what else could be going on?
Even with the Duemilanove bootloader I still get the same error, even switching between Duemilanove and uno under board selection when uploading sketches.

hiduino

I would suggest trying to burn bootloader to the m328p smd again.  Make sure you are selecting Uno board type for burning bootloader.  http://arduino.cc/en/Tutorial/ArduinoISP


Go Up