Pages: 1 [2]   Go Down
Author Topic: send email to gmail ,sucess telnet and not work in arduino  (Read 1494 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 38
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i use my local computer as smtp server (192.168.1.2)

(in the 1# post i attach 2 pic that it success to connect )

Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 115
Posts: 5386
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i use my local computer as smtp server (192.168.1.2)
What email server program do you have installed in your local computer? Is it Exchange? Sendmail? PostFix?

Is your computer firewall allowing port 25 requests?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 38
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i use hMailserver to bypath routing between gmail account

do u know any server to use to check ?
i want only to establish connection between any server
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 115
Posts: 5386
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Then try the gmail email server directly. You should use a local gmail server, so do an nslookup for the ip. From a command prompt
Code:
nslookup
set query=mx
gmail.com
It should list a few email servers. Use the one with the lowest MX preference number. Here is mine:
Quote
C:\Documents and Settings\user>nslookup
Default Server:  ip68-105-28-16.at.at.cox.net
Address:  68.105.28.16

> set query=mx
> gmail.com
Server:  ip68-105-28-16.at.at.cox.net
Address:  68.105.28.16

Non-authoritative answer:
// here is the lowest MX preference
gmail.com       MX preference = 5, mail exchanger = gmail-smtp-in.l.google.com
gmail.com       MX preference = 10, mail exchanger = alt1.gmail-smtp-in.l.google.com
gmail.com       MX preference = 20, mail exchanger = alt2.gmail-smtp-in.l.google.com
gmail.com       MX preference = 30, mail exchanger = alt3.gmail-smtp-in.l.google.com
gmail.com       MX preference = 40, mail exchanger = alt4.gmail-smtp-in.l.google.com

gmail.com       nameserver = ns4.google.com
gmail.com       nameserver = ns1.google.com
gmail.com       nameserver = ns2.google.com
gmail.com       nameserver = ns3.google.com
// Here is the ip for that sever. Use it, but the one your nslookup shows
gmail-smtp-in.l.google.com      internet address = 74.125.134.26
gmail-smtp-in.l.google.com      AAAA IPv6 address = 2607:f8b0:4002:c02::1b
alt1.gmail-smtp-in.l.google.com internet address = 74.125.131.26
alt1.gmail-smtp-in.l.google.com AAAA IPv6 address = 2607:f8b0:400c:c02::1a
alt2.gmail-smtp-in.l.google.com internet address = 173.194.66.26
alt3.gmail-smtp-in.l.google.com internet address = 173.194.65.27
alt3.gmail-smtp-in.l.google.com AAAA IPv6 address = 2a00:1450:4013:c00::1a
alt4.gmail-smtp-in.l.google.com internet address = 173.194.70.26
alt4.gmail-smtp-in.l.google.com AAAA IPv6 address = 2a00:1450:4001:c02::1a
ns1.google.com  internet address = 216.239.32.10
ns2.google.com  internet address = 216.239.34.10
ns3.google.com  internet address = 216.239.36.10
ns4.google.com  internet address = 216.239.38.10
>
C:\Documents and Settings\user>
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 38
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


this is cmd
ip didnt appear
« Last Edit: May 03, 2013, 10:06:03 am by Mohamed_Aouf » Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 115
Posts: 5386
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Then your dns server entries are not set correctly in your network settings for that computer. That is telling you there is no dns server available.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 38
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i solve it by using www.smtp2go.com it is work perfect

thanks a lot bro for your help
Logged

Pages: 1 [2]   Go Up
Jump to: