Go Down

Topic: ChibiOS port will not compile on v1.0.4 (Read 5400 times) previous topic - next topic

z900collector

I downloaded the ChibiOS port and attempted to compile the AVR blink example and I get the following error:

c:/projects/arduino-1.0.4/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr5\libc.a(malloc.o): In function `malloc':
(.text+0x0): multiple definition of `malloc'
core.a(malloc.c.o):C:\Projects\arduino-1.0.4\hardware\arduino\cores\arduino/malloc.c:82: first defined here
c:/projects/arduino-1.0.4/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr5\libc.a(malloc.o): In function `free':
(.text+0x154): multiple definition of `free'
core.a(malloc.c.o):C:\Projects\arduino-1.0.4\hardware\arduino\cores\arduino/malloc.c:194: first defined here

I reread the README and I'm positive Ive put the Chibios_AVR in the libraries folder, and selected the correct board.

Other sketches compile and load fine.

Any pointers?


Sid
Sid Young
http://z900collector.wordpress.com/coding/

z900collector

Further to my last post... I tested this on v1.5.2 and get the same errors

c:/projects/arduino-1.5.2/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr5\libc.a(malloc.o): In function `malloc':
(.text+0x0): multiple definition of `malloc'
C:\Users\SIDNEY~1.WEB\AppData\Local\Temp\build5525742243320212875.tmp/core.a(malloc.c.o):C:\Projects\arduino-1.5.2\hardware\arduino\avr\cores\arduino/malloc.c:82: first defined here
c:/projects/arduino-1.5.2/hardware/tools/avr/bin/../lib/gcc/avr/4.3.2/../../../../avr/lib/avr5\libc.a(malloc.o): In function `free':
(.text+0x154): multiple definition of `free'
C:\Users\SIDNEY~1.WEB\AppData\Local\Temp\build5525742243320212875.tmp/core.a(malloc.c.o):C:\Projects\arduino-1.5.2\hardware\arduino\avr\cores\arduino/malloc.c:194: first defined here

Sid Young
http://z900collector.wordpress.com/coding/

fat16lib

Are you using ChibiOS20130208.zip http://code.google.com/p/rtoslibs/downloads/list.

The 20130208 version of ChibiOS should work with 1.04/1.52.  There are two versions of malloc in 1.04/1.52 and older versions of ChibiOS cause an attempt to link both.

Soon 1.05/1.53 will be released with another version of malloc and ChibiOS will fail again.  I will post a fix as soon as I can test it with the 1.05/1.53 release.

z900collector


Thanks for the reply! I downloaded chibiOS20130208.zip as well as NiRTOS20130201.zip and the FreeRTOS20130208.zip files at the same time so I could try all three. The v1.04 and v1.5.2 installs are fresh default installs. I followed the manual and place the file in the libraries folder and went from there.

is it possible the older codebase was released with a new file name?

Sid
Sid Young
http://z900collector.wordpress.com/coding/

z900collector

OK - so I am puzzled, I loaded up again and now it works fine? no change to library but I did go into the preferences and turned everything on and no compiler errors????

I'll see how it goes.

Thanks

Sid
Sid Young
http://z900collector.wordpress.com/coding/

fat16lib

Quote

is it possible the older codebase was released with a new file name?


Google code does not allow files to be modified or change after they are posted so no files are changed.  You can't even delete files, you can only mark them deprecated so they don't appear in "current downloads".

You can see all files by selecting "all downloads" in the menu above the file list.

I believe Arduino downloads follows the same policy, once posted a file doesn't change.

Go Up