Go Down

Topic: [Solucionado]Problema , No consigo volver a cargar un programa. (Read 4 times) previous topic - next topic

chikolko

May 08, 2013, 08:45 am Last Edit: May 13, 2013, 07:49 am by chikolko Reason: 1
Hace unos dias para un proyecto escolar hice un ejemplo de un sensor de temperatura y un motor , apenas iniciaba con arduino y estaba viendo algunos ejemplos. Cual fue mi sorpresa cuando quería probar otro programa , El IDE Arduino al intentar cargar el nuevo programa me apareció el siguiente mensaje  " Puerto COM3 no encontrado ". En el arduino se quedo grabado el ultimo programa que cargue y hasta la fecha sigue funcionando perfectamente . Mi problema es que no puedo cargarle otro programa al arduino. Nisiquiera mi Pc lo reconoce , los drivers no son el problema porque conecte otros arduinos(de mis compañeros) y mi computadora los detectaba. Mi problema es miarduino.¿ Alguna sugerencia ?

Es un arduino UNO

Ya solucione el problema era el convertidor de USB-Puerto serial que viene siendo el ATMEGA16U2 Que se encuentra detras de los Led TX y RX, Y debia ser reprogramado
He aquí la solución:
http://www.ardumania.es/reflashear-el-8u2/

ADLC

¿Qué modelo de Arduino es?

¿Has probado a ver si en el administrador de dispositivos te lo ha detectado con un número de puerto distinto? (bastaría con que lo hubieses conectado a un puerto USB distinto)
Vinciduino rocks!

fm

Como estabas alimentando el motor?
Con un transistor o a pelo desde un pin de la placa?
   

ADLC

Bueno, fm,
aunque lo haya conectado directamente, como le sigue funcionando el sketch, todavía no habría quemado la placa del todo ... :-)
Vinciduino rocks!

fm

Pero algún puerto si. No sería el primero ni el último.
   

chikolko


Como estabas alimentando el motor?
Con un transistor o a pelo desde un pin de la placa?

Si utilize el transistor junto con el diodo , :(

chikolko


Bueno, fm,
aunque lo haya conectado directamente, como le sigue funcionando el sketch, todavía no habría quemado la placa del todo ... :-)

y si queme alguna parte de la placa , la doy por muerta ?

ADLC

Una de las cosas que más me gusta del AVR es que es realmente duro.
Si no tenías el motor conectado directamente, no hay ninguna razón por la que pensar en que tengas jodida una parte del AVR.

Si es un Arduino UNO, se te puede haber "desprogramador" el ATMega16 que hace de conversor USB-Serie.

¿Qué modelo de Arduino tienes?

¿Cuando conectas el arduino al PC, este hace algún tipo de sonido? ¿Aparece en el administrador de dispositivos, en la parte de puertos COM, aunque sea temporalmente, algún puerto nuevo cuando conectas y desconectas el Arduino?
Vinciduino rocks!

chikolko

#8
May 11, 2013, 05:30 am Last Edit: May 11, 2013, 05:52 am by chikolko Reason: 1

Una de las cosas que más me gusta del AVR es que es realmente duro.
Si no tenías el motor conectado directamente, no hay ninguna razón por la que pensar en que tengas jodida una parte del AVR.

Si es un Arduino UNO, se te puede haber "desprogramador" el ATMega16 que hace de conversor USB-Serie.

¿Qué modelo de Arduino tienes?

¿Cuando conectas el arduino al PC, este hace algún tipo de sonido? ¿Aparece en el administrador de dispositivos, en la parte de puertos COM, aunque sea temporalmente, algún puerto nuevo cuando conectas y desconectas el Arduino?


Es un arduino Uno, cuando lo conecto no hace ningun ruido mi computadora y no aparece en el Admon de Dispositivos , Cuando conecto otro arduino si me aparece como Arduino Uno y hace ruido mi maquina y lo detecta sin problemas. Lo que intente hacer hoy es cambiar el Atmega a otra placa arduino y en la otra placa me funcionaba bien el Atmega y si me dejaba programarlo , Puse el Atmega de una placa Funcional al Arduino 'descompuesto' y no me dejo hacer nada con el.

Hoy programe el Atmega conectandolo a otra placa arduino y pudo grabar el programa que le asigne PERO desde otra arduino. Y Volvio a ensamblar el atmega a su respectivo arduino y el programa que le cargue funciona perfectamente , pero aun asi no puedo cargarle programas desde esa arduino . Si esta quemado algun componente cual puede ser ?

ADLC

Pues entonces todo apunta al ATmega8 o ATmega16 que es el pequeño chip cuadrado que tiene el Uno sodlado directamente en la placa cerca del USB.

Si tienes otros Arduino, puedes usarlo como ISP para reprogramarlo.

Casos como ese ya se han dado y por ahí anda la solución ... si encuentro el post te lo pongo aquí, aunque ahora mismo no lo encuentro.
Vinciduino rocks!

chikolko


Pues entonces todo apunta al ATmega8 o ATmega16 que es el pequeño chip cuadrado que tiene el Uno sodlado directamente en la placa cerca del USB.

Si tienes otros Arduino, puedes usarlo como ISP para reprogramarlo.

Casos como ese ya se han dado y por ahí anda la solución ... si encuentro el post te lo pongo aquí, aunque ahora mismo no lo encuentro.


Si acabo de leer tu comentario y SI! era esto muchas gracias

ArduJona

Hola.!! Yo tuve el mismo problema, intente con los diferentes puertos COM que hay disponibles y aun así no funcionaba, no podía subir programas al micro de la arduino, no hice nada de REFLASHEO DEL FIRMWARE DE ATMEGA, simple porque tenia miedo de dañar mas de lo que estaba. En mi caso, lo único que hice fue irme al Administrador de dispositivos, en donde, en puertos, no aparecía el puerto serial de la arduino (COM3), desconecte la tarjeta y la volví a conectar, la pc no la reconoció, así que me fui a otros dispositivos y ahí estaba como dispositivo no reconocido, luego le di clic derecho, propiedades, controlador y luego en desinstalar, desconecte la Arduino y la volví a conectar al puerto USB del computador, se instala el controlador y listo ya volví a cargar códigos a la ARDUINO.
En mi caso esto funciono espero con ustedes igual.
Saludos colegas Arduineros.

mirkokine

Hola que tal tengo un problema con mi arduino, estoy recien comenzando a trabajar con arduino, ocurre que verifico la programacion y al momento de cargarlo a mi placa me envia un mensaje que el puerto COM5 se encuentra con otro dispositvo y debo desconectarlo, pasa que cuando trabajo con arduino no tengo otros dispositvos en el PC y por ende no puedo cargar las programaciones, que debo hacer, a todo esto mis puertos COM5 y COM3 dicen serie estandar sobr el vinculo BLUETOOTH, si me ueden ayudar seria genial.

Go Up