Go Down

Topic: ebay FT232RL module - not working (Read 3944 times) previous topic - next topic

C2

It just might be defective, but when I try to upload sketch,

Arduino and FT232RL module's LEDs blink back and forth a few times giving me hope, then Arduino goes back to running its already loaded sketch. I get the AVRdude out of sync message.

I've tried selecting all the boards and different programmers in the list, downgraded the FTDI driver, and manually configuring the com port settings (also read somewhere about Set RTS On Close).

No luck and I'm out of ideas.

Erni

Did you try a manual reset when uploading, or swapping the tx/rx lines

Do you have a link to the FT232RL module

C2

My Arduino chip is on a breadboard and I can program it using an OSEPP FTDI board. I also have a couple of mini pro 328s that work with the OSEPP programmer, but nothing with the ebay module.

On the breadboard, I did swap the RX/TX lines - these are being fed through 1k resistors, and I also removed the resistors once.

I tried several variations of pressing the reset button, holding until program byte count is displayed, before/after upload, etc.

This is the module I'm working with:
http://www.ebay.com/itm/1-x-FT232RL-USB-to-Serial-adapter-module-USB-TO-232-Arduino-download-cable-/130748390636?ssPageName=ADME:L:OU:US:3160

If I can't get it to work, I'd like to try some different ones as I need a couple more anyway.

Thanks

Erni

So i guess a loopback test will fail?
I am using one of these, and i've seen others doing the same.

http://www.ebay.com/itm/CP2102-USB-2-0-to-UART-TTL-6PIN-Module-Serial-Converter-/130683943875?pt=LH_DefaultDomain_0&hash=item1e6d5ebbc3

C2

I will test the loopback tonight...I like your module better, cheaper and comes with more...  :)

C2


The latest VCP win driver appears to have a problem.  All I get on it when I loop back is 00 (hex)

Use the older version and it will work - 2.08.24

Docedison

For some reason, Likely the driver as noted but I don't have good luck with the CP2102 devices but always with the FTDI232 modules.. It tool some digging and an accident to find that in my case it was the driver for the CP2102... I accidently re installed something and then my 2102 module started working.

Doc
--> WA7EMS <--
"The solution of every problem is another problem." -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

C2

#8
May 14, 2013, 12:01 am Last Edit: May 14, 2013, 12:08 am by C2 Reason: 1
I think that is the driver I tried, the FTDI driver site has one older version available. Maybe I'll look for others and try again...

P.S., I was going to ask a similar question about an ICSP (ISP) USBasp programmer I bought from the same vendor, ATMEGA8 chip and it seems more complicated because there is driver, firmware, and hardware incompatibilities to consider. I was trying http://www.fischl.de/usbasp/ driver, but might need to flash the chip as well...lots to read on that topic. I already flashed the bootloader on all my bare 328p chips using Arduino as ISP, so not critical now...

suicidalacorn

Hello, i am having the same issue and i have the same usb to serial converter you have. did you ever figure out what was wrong?

C2

I think the one I had was defective and got another one, slightly different brand. It required the older driver that is still available on the FTDI site. The installer is easier, but if you manually update the FTDI device driver, you will also need to manually update the USB bus driver - both from the properties of the item in the Windows device manager...

Darkdoom


I think the one I had was defective and got another one, slightly different brand. It required the older driver that is still available on the FTDI site. The installer is easier, but if you manually update the FTDI device driver, you will also need to manually update the USB bus driver - both from the properties of the item in the Windows device manager...


OMG YOU ARE A LIFE SAVOR! (enough caps for today)

I received one of these clones too and only got 0x00 back. Some threads suggested going back to 2.8.24 .. but I only downgraded the FTDI device driver and never the "USB bus device".

As you suggest update BOTH drivers: The one in the "COM-Port tab" and the other one in "USB-Controllers" too!

ty man!


Work for me when I change the type of card to Arduino Dueminlanov w/ATMega328 on the option menu before start uploading.
I use the last driver from http://www.ftdichip.com/Drivers/VCP.htm, 2.8.30 x64 on windows 8 x64.
:) 8)


The latest VCP win driver appears to have a problem.  All I get on it when I loop back is 00 (hex)

Use the older version and it will work - 2.08.24


Nice work.... would you be so kind and mybe post a LINK to the older version. On the FTD... site there is only the newst version 30... something

Sincerely, VS

Go Up