Go Down

Topic: Arduino con piedini non attivi eroga corrente? (Read 485 times) previous topic - next topic

GioJoker

Salve a tutti, ho sui piedini del mio arduno dei transistor a cui è collegata l' alimentazione da 12 V e qualche led con una resistenza. Nel momento in cui un piedino è attivo i led si accendono correttamente nel modo giusto. Quando tutti i piedini sono settati su LOW l'arduino è come se mi erogasse una piccola dose di corrente sui piedini 12 e 13, forse dovuta all'alimentazione da 12 volt sui transistor creando così un circuito e accendendo in piccola luminosità i led. Non trovo altre spiegazioni, ma soprattutto come posso evitare questo, è estremamente importante perchè quei led dovrebbero stare spenti, grazie in anticipo.



GioJoker

Sono npn, come dovrei utilizzarla la resistenza pull-down? Il mio circuito è già stato stampato e risulterebbe difficile modificarlo

PaoloP

Prova a fare un collegamento volante con una resistenza da 10K ohm tra la base del transistor (o l'uscita dal piedino, se è più comodo) e GND.

GioJoker

Ne ho utilizzata una 2Kohm, precisamente seguendo questo schema: http://arduino.cc/forum/index.php/topic,146152.0.html figura 2 led in serie

pighixxx


Ne ho utilizzata una 2Kohm, precisamente seguendo questo schema: http://arduino.cc/forum/index.php/topic,146152.0.html figura 2 led in serie


Ciao sono PighiXXX, l'autore di quegli schemi.
Quanti led hai messo in serie? Che transistor hai usato?
La prima prova che puoi fare, a prescindere dalle risposte  :D, è aumentare il valore della resistenza tra l'uscita del pin Arduino e la base del transistor. 6.8K per esempio.

uwefed

Quale Arduino stai usando?

Fino alla Arduino UNO R2 sul pin 13 c'éra messo un LED con una resistenza da 500 OHM a massa. Quello poteva dare problemi ai circuiti collegati.
Siccuramente non da problemi a un Transistore NON collegato. e poi dovrebbe dare questo efetto solo sul pin 13 e non sul pin 12.
Che valore di resistenza base hai usato? Che transistor stai usando?
Hai per caso invertito il collettore e emettitore dei transistori collegati al pin 12 e 13?

Ciao Uwe




leo72


Quando tutti i piedini sono settati su LOW

La domanda sembrerà stupida ma la faccio comunque: ti sei ricordato di attivare i pin come output?

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy