Go Down

Topic: Problems running/ building Arduino IDE from Eclipse (Read 618 times) previous topic - next topic

Hi everybody!!

I'm trying to make some changes on the Arduino IDE but when I try to run or build the IDE to check if the changes are working I have found problems so I can't.

I have followed this two tutorials:
- http://naniktolaram.com/?p=306.

- http://www.youtube.com/watch?v=7MPktOcmzjk

The steps I have followed are:
- Download the source code of arduino form https://github.com/arduino/Arduino and unzip it.
- Follow the tutorials.

They take me to the same point where I have found the following errors:
- When I try to run by Eclipse:

Code: [Select]
Exception in thread "main" java.lang.UnsatisfiedLinkError: jnidispatch (/com/sun/jna/win32-amd64/jnidispatch.dll) not found in resource path
at com.sun.jna.Native.loadNativeLibrary(Native.java:471)
at com.sun.jna.Native.<clinit>(Native.java:91)
at processing.app.windows.Platform.<clinit>(Platform.java:280)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:188)
at processing.app.Base.initPlatform(Base.java:211)
at processing.app.Base.main(Base.java:110)


- When I try to build it with ant I achieve it, but when I try to run the new arduino IDE it give me back:

        Java Virtual Machine Launcher:   Could not find the main class: processing.app.Base. Program will exits.

So I can't check anything.
The main in processing.app.Base is inside the project so I'm totally lost.

I have looked for the solution trought google and this forum and I haven't found the solution.

I would be pretty glad if someone give me the solution.
Thanks to everyone!!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy