Go Down

Topic: Arduino +Ethernet = funktioniert nicht (Read 627 times) previous topic - next topic

DonQuijote

May 11, 2013, 05:16 pm Last Edit: May 11, 2013, 05:38 pm by DonQuijote Reason: 1
Hallo zusammen,

Irgendwie schaffe ich es nicht mit dem BeispielSKetch >Webserver für das Ethernet Shield was im Browser anzeigen zu lassen. Ich frage wieso, ich habe den Sketch abegändert, nachdem ich herausgefunden habe das ich im Netzwerk mit 192.168.2.X.X bewege und das auch im Arduino angepasst habe geschieht trotzdem nichts. Wenn ich den Arduino versuche anzupingen kommt leider = "Zielhost nicht erreichbar", das kann doch nicht so schwer sein :(

Das ganze habe ich an meinem Router angeschlossen






Marcus W

Ein bisschen mehr code wäre hilfreich...

DonQuijote

#2
May 11, 2013, 07:50 pm Last Edit: May 11, 2013, 09:04 pm by uwefed Reason: 1
Das ist wie gesagt der Beispielsketch :

Datei > Beispiele > Ethernet > WebServer


Code: [Select]
/*
 Web Server

A simple web server that shows the value of the analog input pins.
using an Arduino Wiznet Ethernet shield.

Circuit:
* Ethernet shield attached to pins 10, 11, 12, 13
* Analog inputs attached to pins A0 through A5 (optional)

created 18 Dec 2009
by David A. Mellis
modified 9 Apr 2012
by Tom Igoe

*/

#include <SPI.h>
#include <Ethernet.h>

// Enter a MAC address and IP address for your controller below.
// The IP address will be dependent on your local network:
byte mac[] = {
 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED };
IPAddress ip(192,168,2, 106);

// Initialize the Ethernet server library
// with the IP address and port you want to use
// (port 80 is default for HTTP):
EthernetServer server(80);

void setup() {
// Open serial communications and wait for port to open:
 Serial.begin(9600);
  while (!Serial) {
   ; // wait for serial port to connect. Needed for Leonardo only
 }


 // start the Ethernet connection and the server:
 Ethernet.begin(mac, ip);
 server.begin();
 Serial.print("server is at ");
 Serial.println(Ethernet.localIP());
}


void loop() {
 // listen for incoming clients
 EthernetClient client = server.available();
 if (client) {
   Serial.println("new client");
   // an http request ends with a blank line
   boolean currentLineIsBlank = true;
   while (client.connected()) {
     if (client.available()) {
       char c = client.read();
       Serial.write(c);
       // if you've gotten to the end of the line (received a newline
       // character) and the line is blank, the http request has ended,
       // so you can send a reply
       if (c == '\n' && currentLineIsBlank) {
         // send a standard http response header
         client.println("HTTP/1.1 200 OK");
         client.println("Content-Type: text/html");
         client.println("Connection: close");
         client.println();
         client.println("<!DOCTYPE HTML>");
         client.println("<html>");
                   // add a meta refresh tag, so the browser pulls again every 5 seconds:
         client.println("<meta http-equiv=\"refresh\" content=\"5\">");
         // output the value of each analog input pin
         for (int analogChannel = 0; analogChannel < 6; analogChannel++) {
           int sensorReading = analogRead(analogChannel);
           client.print("analog input ");
           client.print(analogChannel);
           client.print(" is ");
           client.print(sensorReading);
           client.println("<br />");      
         }
         client.println("</html>");
         break;
       }
       if (c == '\n') {
         // you're starting a new line
         currentLineIsBlank = true;
       }
       else if (c != '\r') {
         // you've gotten a character on the current line
         currentLineIsBlank = false;
       }
     }
   }
   // give the web browser time to receive the data
   delay(1);
   // close the connection:
   client.stop();
   Serial.println("client disonnected");
 }
}


skorpi08

Ganz einfach erklärt. Der ICSP hat kein Kontakt mit dem Arduino. Entweder alle kürzen oder den ICSP anschluss verlängern. Schon mehrmals hier im Forum diskutiert.
Nicht Mensch, nicht Tier: Programmierer halt...

DonQuijote

#4
May 11, 2013, 08:04 pm Last Edit: May 11, 2013, 08:11 pm by DonQuijote Reason: 1
ICSP kann es nicht sein, habe das mit dem Multimeter mal gecheckt alle Verbindungen sind einwandfrei. Bitte vorsichtig mit solchen Tips

skorpi08

#5
May 11, 2013, 08:13 pm Last Edit: May 11, 2013, 08:15 pm by skorpi08 Reason: 1
Mach mal diese "Plastik Halterung" (vom ICSP) ab von dem Ethernet Shield und steck auf Arduino drauf. Dann schau wie es aussieht
Nicht Mensch, nicht Tier: Programmierer halt...

DonQuijote

#6
May 11, 2013, 08:20 pm Last Edit: May 11, 2013, 08:23 pm by DonQuijote Reason: 1
Sieht nicht bündig aus aber der Multimeter pipst wenn ich jeweils die Lötstellten am Arduino und am Ethernet Shield kontere


DonQuijote

Yesssss, es funktioniert !

An was es gelegen hat ? Falsche Com Port Einstellung  XD


Go Up