Pages: [1] 2   Go Down
Author Topic: Led "L" sempre accesa  (Read 1143 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ragazzi ho un problema con il mio arduino duemilanove. Mi rimane acceso fisso il led con accanto la lettera L e se provo a caricare un nuovo sketch dal computer mi da un errore di sincronizzazione(error sync, una cosa del genere). Qualcosa mi sa dare una mano?
Logged

Switzerland
Online Online
Faraday Member
**
Karma: 113
Posts: 5952
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

... bé ... magari se descrivi l'antefatto ... qualcuno può cercare di aiutarti, ma con queste info cosa vuoi che si inventa ???

Guglielmo
Logged

Search is Your friend ... or I am Your enemy !

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si scusa hai ragione, anche se, non c'è molto da raccontare. Ho accesso l'Arduino con uno sketch già caricato e si è subito acceso il led rosso in modo fisso. Ho provato a resettarlo più volte, a togliergli l'alimentazione e a caricarci un nuovo sketch ma, appunto, mi da questo errore di sincronizzazione. Ah, e lo sketch che è caricato sull'arduino non viene eseguito.
Logged

Switzerland
Online Online
Faraday Member
**
Karma: 113
Posts: 5952
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

... un passetto alla volta eh ...

... Che fa questo sketch ? Come lo hai caricato ? Ti ha dato errori in fase di caricamento ? Ha mai funzionato o ... appena caricato si è piantato il tutto ?

Guglielmo
Logged

Search is Your friend ... or I am Your enemy !

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Lo sketch funzionava correttamente. L'unica modifica che ho fatto prima dell'ultima accensione è stata quella di aver collegato dei PIN che prima erano scollegati. Lo sketch comanda 5 schede di controllo di motori passo passo mediante l'utilizzo di un joystick per ps2. Ma il programma ha sempre funzionato, è da 2-3 giorni che lo uso, però appunto non avevo ancora mai collegato tutti i PIN che prevedeva il programma.
Logged

Switzerland
Online Online
Faraday Member
**
Karma: 113
Posts: 5952
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ahi ... cosa è collegato a quei pin ? E ... quanti mA assorbe tutto quello che ci hai collegato ?

Guglielmo
Logged

Search is Your friend ... or I am Your enemy !

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Erano collegati a degli ingressi di due integrati, però almeno in teoria, dovevano essere ancora tutti a livello basso.
Logged

Switzerland
Online Online
Faraday Member
**
Karma: 113
Posts: 5952
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

... mi sa tanto che a questo punto ... c'è bisogno di uno schema dei collegamenti e dei componenti usati ...  smiley-roll

Guglielmo
Logged

Search is Your friend ... or I am Your enemy !

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ma generalmente cosa sta a significare quel led?
Logged

Marche
Offline Offline
Edison Member
*
Karma: 34
Posts: 2272
azioni semplici per risultati complessi
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

E' collegato al pin digitale 13, se lo imposti come uscita e la setti ad HIGH si accende.
Non ha scopi particolari
Logged

Switzerland
Online Online
Faraday Member
**
Karma: 113
Posts: 5952
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quel LED è il solito LED che stà sulle varie board ... quello collegato al "digital pin 13" ... lo vedi nello schema qui : http://arduino.cc/en/uploads/Main/arduino-duemilanove-schematic.pdf ... in alto a destra, collegato al pin fisico 19 del chip (PB5) ... e, sempre acceso, non è una bella cosa ...  smiley-roll

Guglielmo

Edit : Ci siamo sovrapposti con pelletta smiley-lol
Logged

Search is Your friend ... or I am Your enemy !

BZ (I)
Offline Offline
Brattain Member
*****
Karma: 262
Posts: 21581
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hai collegato qualcosa ai pin 0 e 1?
Togli tutto dal Arduino e riprova di caricare uno sketch per esempio quello di Blink che trovi nei esempi del IDE.
Il LED L viene pilotato dal Pin 13. Stai usando nello sketch quel pin?
Dacci lo sketch.
Ciao Uwe

Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Non riesco a cambiare sketch perché mi da errore di sincronizzazione...
avrdude: stk500_getsync(): not in sync: resp=0x00
Logged

Marche
Offline Offline
Edison Member
*
Karma: 34
Posts: 2272
azioni semplici per risultati complessi
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hai un altro arduino? Se sì prova a ricaricare il bootloader sul micro incasinato.
Inizialmente quando mi capitava risolvevo così, so che c'entra poco ma funzionava alla grande.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Scusa l'ignoranza, ma il bootloader cosa sarebbe?
Logged

Pages: [1] 2   Go Up
Jump to: