Pages: [1]   Go Down
Author Topic: arduino Eclipse MAC and Windows  (Read 503 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 152
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had problems with my pc and i have to format it.I was working with arduino Eclipse on Mac and on Windows.

I have some projects going on .I installed the arduino on Mac and eclipse c/c++ i installed avr plugin as i had before also rxtx and terminal.I have setted the paths for avrdude correctly.I have cloned my repositories from mercurial that worked fine to the workspace(arduinoCore and the rest projects) and i tried to built them.

I have semantics error, the compiler does not understand the arduments and gives me errors at functions like pinMode()  digitalWrite()   Serial.print().

What can i do "Arduino.h" is included already. The arduinoCore project is the same that it is provided at the playground tutorial for setting arduino with eclipse.

At windows i get the same error plus that i can not create the .hex file
Logged

Offline Offline
Sr. Member
****
Karma: 7
Posts: 275
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am not exactly sure what you are trying to do but...

If you want to run Eclipse to compile Arduino code then there is no better way of doing that than the newest V2.1.0.4 version of the Arduino Eclipse plugin:
http://iloapp.baeyens.it/blog/blog?

I've written some installation instructions:
http://trippylighting.com/teensy-arduino-ect/arduino-eclipse-plugin-installation/
Logged


Pages: [1]   Go Up
Jump to: