Pages: [1]   Go Down
Author Topic: Relais klackert, schaltet trotzdem nicht...  (Read 495 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

ich habe folgendes Relais: http://www.conrad.de/ce/de/product/502972/Miniatur-Leistungsrelais-Serie-FTR-H1-Takamisawa-FTR-H1-CD-012-12-VDC-1-Wechsler-Max-10-A-Min-5-VDC-Max-300-VDC

an meinem Arduino laut folgender Anleitung/Schema http://forum.arduino.cc/index.php?/topic,154549.0.html angeschlossen. Setcard 1/Relais.

Nun höre ich das Relais klackern, wenn ich den Pin an dem es angeschlossen ist auf high schalte. Nur leider tut sich nix an der dahinter geschalteten Hardware.

Da das Relais ein Wechselrelais ist, funktioniert die nachfolgende Hardware, wenn das Relais nicht bestromt wird und auf Durchlass ist. D.h. die angeschlossene Komponente funktioniert an sich.

Mich wundert das man das Relais schalten hört, sich aber im Endeffekt am Schaltzustand nichts ändert. Kann mir jemand sagen woran das liegt???
Logged

Offline Offline
Edison Member
*
Karma: 38
Posts: 1164
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Wird das Relais mit 12V versorgt?

Falls ja, bleiben nur zwei Möglichkeiten:
Relais ist kaputt, oder falsch angeschlossen.
(letzteres ist die häufigere Ursache)
Logged

Grüße
Gunther

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 266
Posts: 21665
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mit welcher Spannung versorgst Du das Relais, Welchen Transistor nimmst Du? Welchen Basiswiderstand hast Du gewählt?
Grüße Uwe
Logged

Germany
Online Online
Edison Member
*
Karma: 47
Posts: 2321
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Mit welcher Spannung versorgst Du das Relais, Welchen Transistor nimmst Du? Welchen Basiswiderstand hast Du gewählt?
Grüße Uwe
Wenn er sich auf die verlinkte Beschaltung bezieht, kann man ja von einem BC557 (npn-Transistor) mit einem Basiswiderstand von 2k2 ausgehen. Fraglich ist jedoch, ob der Transistor richtig angeschlossen ist. Im Link fidnet man zwar eine schematische Darstellung, aber je nach Interpretation ist das die Ansicht des Transistors von unten (Pins sichtbar) oder von oben (Lage der Pins markiert).
Daher würde mich ein aussagekräftiges Foto der Schaltung und der auch Quellcode interessieren.
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Möchte einmal Rückmeldung geben woran es gelegen hat.

Ich habe die Spule ebenfalls an die 5V Versorgung des Arduino gelegt. Dies hat ausgereicht um das Relais zum klackern zu bringen, schlussendlich war es dann aber doch zu wenig.

Bei 12V klackert das Relais nun deutlicher/lauter und schaltet sauber durch.

Vielen Dank für eure Hilfe.
Logged

Pages: [1]   Go Up
Jump to: