Pages: [1]   Go Down
Author Topic: Fehleranalyse Led Matrix mit dem Max7219  (Read 248 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich habe eine Matrix gebaut mit dem Max7219 und wenn ich nun das Displaytestregister aufrufe passiert das hier:


ich hatte das erst unten rechts, da hat einmal frei kratzen der Unterbrechungen am IC geholfen aber nun passiert das halt.

Wo könnte ich ansetzen? Könnten es wieder die Unterbrechungen sein?
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok hat sich erledigt es war eine kalte Lötstelle smiley-wink

Logged

Germany, Dresden
Offline Offline
Sr. Member
****
Karma: 16
Posts: 436
30 Jahre Elektronikbastelei, Programmieren null Ahnung!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Die Matrix hast du aus Einzel-LEDs aufgebaut? Vielleicht die LEDs verkehrt rum? Miß mal im ausgeschalteten Zustand mit einem DVM die Schwellspannung der LEDs und der Nachbarn. vielleicht findest du da schon Auffälligkeiten. Reagiert der MAX auf seinen Code, oder ist nur immer das selbe Bild? Es gab davon schon Fake Chips, wor nur ein bisschen was funzelte, egal, was man für Code an den Chip schickte. waren sehr primitive Fälschungen, wo nicht mal das Logo stimmte. Hatten wir schon mal im Forum ausgewertet. war so ca. Feb. rum.

Gruß Gerald
Logged

rot ist blau und Plus ist Minus

Pages: [1]   Go Up
Jump to: