Go Down

Topic: Arduino Nano v3 atmega 328p avrdude: stk500_getsync(): not in sync: resp=0x00 (Read 29338 times) previous topic - next topic

muhkuharduino

i get this error:

avrdude: stk500_getsync(): not in sync: resp=0x00

when trying to upload a example sketch.

pin (0,1) are not occupied; it is the right serial port with latest drivers i choosed the right board

The RX led blinks 2 or 3 times when i try to upload.

Full log:

avrdude: Version 5.11, compiled on Sep 2 2011 at 19:38:36 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

     System wide configuration file is "D:\Utz\Downloads\arduino-1.0.4\hardware/tools/avr/etc/avrdude.conf"

     Using Port                    : \\.\COM3
     Using Programmer              : arduino
     Overriding Baud Rate          : 57600
avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Recv: avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done. Thank you.

muhkuharduino

woops, don't know why search didn't show up with it but manual look does: http://forum.arduino.cc/index.php?topic=165924.0 very simmilar problem, but no working solution..

also  tried what is described on the last answer : http://arduino.alt245.com.ar/how-i-dealt-with-this-error/ :/


Moderator edit: session id removed

Louis Davis

Does the loopback test pass or fail?
http://forum.arduino.cc/index.php?topic=73748.0

muhkuharduino

In short I shell just:

connect the two upper left
connect the two upper right but one (in other words: second and third from top on the right side )


pins and then connect it to the pc and send someething via terminal ?

Laboratory just closed, looking for some jumper from my old pc


//EDIT:

found them. did the test with arduino serial monitor. Letters just disappear after pressing SEND no ECHO :/

Louis Davis

What version of the FTDI VCP drivers do you have installed?
http://www.ftdichip.com/Drivers/VCP.htm

You could try updating the FTDI drivers.

muhkuharduino

I installed them just a few hours ago, they are up to date :/ Also tried it on my notebook and on every usb slot
2.08.28 for 64 bit Windows

tracerboy


Louis Davis

There is some indication in this thread that going back to 2.08.24 fixed his problem:

http://forum.arduino.cc/index.php?topic=165310.msg1238147#msg1238147

muhkuharduino



muhkuharduino

#10
May 15, 2013, 10:48 am Last Edit: May 15, 2013, 08:06 pm by muhkuharduino Reason: 1
WTF

yesterday I was working on my desktop computer.. I just installed the old drivers on my laptop AND RESTARTED (as I were requested) and changed the baudrate from 9600 to 57600 under device manager -> comport. (dont thing this is neccessary)

AND IT WORKS! Upload is working just fine!


ps: just in case i would have shortened the bottom+top ICSP pins on the right and those on the left while connected via usb but my upload still works: could something be damaged ?

tracerboy

I had no success so far. Duzends of reboots, using FTDI drivers 2.8.24.0 and changing the port to 57600 bps did not solve the problem for me...

muhkuharduino

I'm sorry to hear that. Maybe you should then mark it as defect and claim for a new working one :/

tracerboy

I got my USBtinyISP with that one I'm able to flash my sketches through this ISP programmer!

And I got a new Nano V3 (the third one - same brand, two different suppliers) - still unable to flash directly via FTDI/USB.
Either the FTDI/UART-Interface of the complete series is broken or it's a driver issue.

I tried 2.8.28 and 2.8.24 from this source: http://www.ftdichip.com/Drivers/VCP.htm, the 2.8.28 from Windowsupdate (which seems to be the same as the one provided by ftdi), and the 2.8.14 shipped with arduino IDE. The COM-port is set up correctly without errors for all three of them, but while flashing via usb I still get the message:

Quote
avrdude: stk500_getsync(): not in sync: resp=0x00


Reflashing the bootloader works, but does not solve the problem.

I have no plan how to get that to work, still I would be happy for any hint...

Louis Davis

Can you provide a link to the Nano's you have?
Are these official Arduino Nano's or clones?

Which bootloader are you flashing onto them?

Since you are able to flash sketches with the ISP, can you verify the serial interface is working by flashing a sketch that uses the serial interface and interact with the Nano using the Serial Monitor. Start with the ASCIItable example or something similar to that.

This will help narrow down if you are having problems with the USB - serial interface or if it is isolated to the bootloader.

Go Up