Pages: [1]   Go Down
Author Topic: WIFI shield werkt niet meer na update van firmware  (Read 3047 times)
0 Members and 1 Guest are viewing this topic.
Nederland
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

nadat ik mijn wifi shield heb geupdate volgens de arduino procedure, dus met atmel flip 3.4.7 en de 2 filetjes heb geupload wifiHD.elf en wifi_dnld.elf werkt het schildje niet meer.
Als ip nummer geeft hij 0.0.0.0
Als ik het scan programmatje laad dan werkt het wel
wat is hier aan de hand.

bijgevoegd een van de 2 terugmeldingen



* Knipsel.JPG (44.82 KB, 533x229 - viewed 43 times.)
Logged

Nederland
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo mede arduino fans,

Na de voorgaande pogingen, waar ik volgens mij niets fout heb gedaan ben ik verder gegaan met het uploaden van andere, en voorgaande versies van de firmware van het arduino wifi shield. Ook de versies wifihd_2_1.elf en dnld_2_1.elf heb ik geprobeert. Bij al deze versies reageert mijn Wifi shield anders.
Bij de laatste vrijgegeven versie werkt mijn wifi shield weer zo goed als normaal, dus hij vind weer het juiste ip adres, maar mijn seriale communicatie laat nu regelmatig verminkte text zien, en ook mijn internetverbinding is nog steeds onbetrouwbaar. In ieder geval ben ik er van overtuigd dat ik de firmware op de juiste manier heb geupload in mijn arduino wifi shield, want ik krijg buiten de normale waarschuwing dat het programma wordt overschreven verder geen foutmeldingen. Ik heb gisteren dan ook besloten om mijn arduino wifi schield om te ruilen tegen een nieuw printje, want ik denk dat mijn printje niet echt betrouwbaar is, mede ook omdat ik op deze site weinig of geen berichten zie die hetzelfde probleem hebben.
Zogauw ik mijn nieuwe print binnen heb laat ik weten of mijn problemen zijn opgelost.

grtz frans smiley-sad
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 211
Posts: 13478
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Heb je de soldeerverbindingen van je shield gecontroleerd?

Ik heb dat ooit bij een ander shield gehad dat nadat ik alle verbindingen even had aangetipt met de bout hij het beter deed. (eerst kijken met vergrootglas kan ook smiley-wink
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Nederland
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Rob,

bedankt voor je reactie.
Ik heb de soldeer verbindingen niet gecontrolleerd, maar ik denk inderdaad dat je gelijk hebt, omdat het laden van de firmware steeds goed gaat, terwijl het board steeds anders reageert. In ieder geval heb ik over een paar dagen een nieuwe print. Ik laat je weten of mijn probleem dan is opgelost.

grtz frans
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 211
Posts: 13478
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

OK
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Nederland
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Het probleem is opgelost.
Het bovenbeschreven probleem had meerdere oorzaken, maar de hoofd oorzaak was toch een defect Wifi shield. Nadat ik het printje had vervangen door een nieuw exemplaar waar ik maar liefst 3 weken op heb moeten wachten kon ik het programma uren zonder problemen laten werken.
Een ander probleem was onder andere de voeding die ik voor de UNO gebruikte. Ik had hier een van de standaard snoervoedingen gebruikt die ik nog een aantal had liggen, maar die gigantisch in elkaar storten als je deze gaat belasten. het heeft dagen geduurd voor ik dit in de gaten had.
Verder gaf mijn internet repeater problemen. Hoewel deze een sterker signaal afgaf dan mijn router weigerde het wifi shield te werken wanneer ik het via de repeater probeerde.
verder is het zo dat de hostnaam hoofdletter gevoelig is, waardoor ik soms wel een hoofdletter gebruikte, en andere keren weer niet.

Omdat ik met meerdere problemen te maken had was het erg moeilijk om de vinger op de zere plek te leggen, maar nu werkt het Wifi shield perfect. smiley-grin  smiley-razz  :lol:

grtz frans
Logged

Forum Moderator
Belgium
Online Online
Edison Member
*****
Karma: 68
Posts: 1893
Arduino rocks; but with my plugin it can fly rocking the world ;-)
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

frans bedankt voor de update.
Logged

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 211
Posts: 13478
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Goed om te weten van die repeater.

Quote
Ik had hier een van de standaard snoervoedingen gebruikt die ik nog een aantal had liggen, maar die gigantisch in elkaar storten als je deze gaat belasten. het heeft dagen geduurd voor ik dit in de gaten had.

Een goedkope multimeter uit de grabbelbak bij de benzinepomp had je hier kunnen helpen smiley-wink
Als ze er weer liggen neem ik er een paar mee, kan ik eindelijk op meer dan 2 plaatsen in mijn opstelling meten (Heb nu 1 profi en 1 goedkope)
« Last Edit: May 16, 2013, 12:13:53 pm by robtillaart » Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Pages: [1]   Go Up
Jump to: