Go Down

Topic: GLCD Modello QC12864B (Read 4 times) previous topic - next topic

pighixxx

mancano ancora un paio di cose che ti ho chiesto...

AxlRose94s






Scusate la bassa qualità ma è l'unica possibilità  :~

Mancava questo giusto??  :D

Testato

- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

pighixxx

1° Hai collegato sui 3.3V invece che sui 5 (almeno da quello che vedo)
2° Non hai collegato il trimmer

AxlRose94s

No, infatti, non l'ho collegato...ma esso serve soltanto a regolare il contrasto, era collegato fino a poco fà!
Ho alimentato tutto a 3,3V perchè con i collegamenti fatti in quel modo, a 5V arduino và in protezione, si spegne. Hai qualche idea??

pighixxx


(cut)
Ho alimentato tutto a 3,3V perchè con i collegamenti fatti in quel modo, a 5V arduino và in protezione, si spegne. Hai qualche idea??


:smiley-roll-blue:

Fai così:
-Stacca da Arduino il cavo rosso, giallo e verde (quelli collegati ai pin 5,8 e 9) che arrivano dalla breadboard.
-Sposta il cavo da 3V3 A 5V
-Assicurati che Arduino sia ancora vivo (Caricando lo sketch Blink per esempio)
-Cosa succede? (Descrivi cosa succede all'lcd e se lampeggia il led di Arduino)

AxlRose94s

Appena collego a 5v si spegne arduino. Sempre a meno che non stacco il pin PSB o il pin VDD, in tal caso, come detto, il display si illumina...non sò che fare...

MauroTec

ma senza collegare il pin PSB la retroilluminazione funziona?
No perchè come ho detto assorbe 360mA e tu stai usando la usb per alimentare il tutto.
Quindi vorrei capire se la luce si accende senza collegare PSB.

Ciao.
AvrDudeQui front end per avrdude https://gitorious.org/avrdudequi/pages/Home

AxlRose94s

Ciao Maurotec,
si la luce si accende solo ed esclusivamente se scollego il PSB o se scollego il VDD.

pighixxx


Appena collego a 5v si spegne arduino. Sempre a meno che non stacco il pin PSB o il pin VDD, in tal caso, come detto, il display si illumina...non sò che fare...


Hai semplicemente un corto.
Ricontrolla tutto. Arduino funziona ancora?

AxlRose94s

Si, arduino funziona correttamente...
Anche io ho pensato ad un corto, ma com'è possibile, ho ricontrollato mille volte, non ci sono errori...Ho rispettato del tutto la piedinatura...

pighixxx

Controlla anche le saldature. Se hai un tester controlla i piedini attigui dell'lcd per vedere se c'è un corto.

AxlRose94s

Le saldature sono apposto, il tester non ce l'ho, e ahimè non saprei nemmeno come utilizzarlo  :smiley-roll-blue:  Provo a vedere se entro domani riesco a farlo testare da qualcuno di mia conoscenza, Grazie per adesso, farò sapere l'esito. :)

AxlRose94s

Ho capito da dove è generato il corto, dal pin PSB escono 5v o comunque una tensione positiva!
Ti spiego, ho collegato un led sulla breadboard, un piedino GND e l'altro l'ho collegato con il pin PSB, il led si è acceso!
Come è possibile questa cosa????  :smiley-eek:

Testato

E ritorniamo alla mia risposta precedente :-)
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

Go Up