Go Down

Topic: WiFi shield unresponsive after a while (Read 1 time) previous topic - next topic

HackWar

Hi all, I just picked up the WiFi shield and stacked it on top of my Arduino DUE and it connects smoothly to my router. After the connection test I tried to serve a web page using the WiFiWebServer example. Unfortunately this only works sometimes (most of the time it does not). It just seems to respond at random but fails 80 percent of the time (timeout). I've seen some posts on this but not a real solution to this problem. I've updated the firmware to the latest version. Does anyone know how to resolve this?

liudr

Are you using arduino official wifi shield?

What client are you using to view the arduino web page?

HackWar

Hi Liudr, thanks for your reply.

Yes I'm using the official shield as seen here:

http://arduino.cc/en/Main/ArduinoWiFiShield

I tried a regular browser like Chrome or IE but both come up with the same results. I also tried pinging the WiFi shield and many pings seem to fail, only a small percentage gets back.

MattS-UK

I have a shield running on a Mega which has been up and serving a simple web page for the last three days, with a 30 second refresh in the headers.
It responds to pings reliably, even when actively serving a page.
It doesn't like concurrent requests but recovers.
I am not entirely sure what firmware version I am running.
Sadly my Uno just wasn't up to the job.

Before presuming a fault with the firmware or the shield, you should check the bases.
Use the library RSSI function to see what the signal strength is.
Check your environment for sources of (2.4Ghz) radio interference.
Signal quality is expressed as Signal to Noise but unfortunately you need a spectrum analyser to measure the noise.
Check the pins your Arduino board uses to communicate with the shield, are not being used for anything else.





liudr

There might be some compatibility issues between DUE and wifi shield. Do you have an Arduino MEGA? I am also using MEGA and my wifi shield R3 with original firmware has been working pretty well as web server except for a few quirks.

Go Up