Go Down

Topic: Motor DC+ Driver Ponte H - Motor não tem força (Read 2275 times) previous topic - next topic

futepa

Comprei uma ponte H pronta no mercado livre desse modelo http://produto.mercadolivre.com.br/MLB-472801834-driver-motor-ponte-h-l298n-codigo-arduino-_JM, e estou tendo problemas pq os motores que uso são de 4,5v cada, sempre que ligo no drive o motor não tem força suficiente para empurrar o veiculo, porem se ligo direto ele consegue. Primeiro liguei uma fonte externa com 3x 1,2v pilhas, como eu disse, sem a ponte funciona normal com ela fica sem força, mudei para uma bateria de 9v e o problema se repete!

Tem algo que eu deva fazer no driver para aumentar a potencia? ou esse driver não presta?
No arduino utilizei as portas PWN para acionar os motores!!

Mortis

futeba,

Você deixou o jumper 5v enable? Pois se o jumper ficar, os motores serão alimentados pelos 5V do regulador de tensão (78M05). Esse conector, onde marca 5v, serão saída de 5v se estiver com o jumper e entrada de 5v se estiver sem o jumper.

No arduino qual valor você definiu para o PWM?


futepa

defini como 255, era a unica maneira de o carro se movimentar um pouco

Mortis

Entendi...

Você fez o teste só com o drive? Ligando a bateria de "9v+ em 12v" e "9v- em GND" e ligando um fio do 5V no IN1 por exemplo? Neste caso, com o 5V enabled conectado. O motor deverá se mover com a tensão de 5v? Lembrando que motores DC consomem muita corrente e a bateria de 9v costumam ter pouca capacidade neste sentido, o melhor seria um conjunto de pilhas AA de uns 1500 mAh.

Dá uma olhada nesse post, o pessoal comentou um pouco sobre o drive http://forum.arduino.cc/index.php?topic=120619.0

futepa

bem, eu tirei o jumper de 5v e sem ele não fluia corrente, é só colocar o jumper q volta.
O meu esta ligado assim:

pilhas AA nas entradas gnd e +12v
aduino saida 5v na entrada +5v do drive

Mortis

#5
May 22, 2013, 03:10 am Last Edit: May 22, 2013, 03:18 am by Mortis Reason: 1
desculpe-me, esqueci de comentar que o driver precisa de pelo menos 6v na entrada 12v, o ideal é a partir de 7v, pois o regulador de tensão recebendo 4,5v (3x 1,5) não mandará muita energia para os motores para o IC. Você tem um multimetro? Se tiver pode fazer medições nas saídas para saber quantos volts estão disponíveis para o motor e na bateria para saber se ela já não esta gasta.

Mortis

O jumper alimenta a parte lógica do l298n, se você tirar o jumper terá de "colocar" 5v no conector 5v da drive, se não o IC (l298n) fica sem alimentação.

Tira o jumper "5v enable" e testa a seguinte conexão:
12v liga a bateria de 9v
GND liga o menos da bateria de 9v e liga no GND do arduino (como a referência é ground, ele precisa ser comum)
5v liga no 5v do arduino
Out nos motores e pwm nos IN#

diz o que contece ;)

futepa

Hum, entendi, parece que me faltava ligar no terra do ardunio junto com o terra da bateria 9v. Vou tentar

Mortis

Sim... sem o gnd comum o circuito "não fecha".

Mortis

E antes de eu ir dormir rs

Veja o pdf do L298, é bom se acostumar com os datasheets, eles são muitíssimo importantes ^^
http://www.tech.dmu.ac.uk/~mgongora/Resources/L298N.pdf

No arquivo acima, verás que a tensão mínima para a parte lógica do L298 é de 4,5v, logo 4,5v passando pelo regulador de tensão cairão para 3,8 (essa parte foi um chute rs) o que esta abaixo do especificado em "ELECTRICAL CHARACTERISTICS".

futepa

Sem muito sucesso, continua fraco, vou tentar aumentar a voltagem aumentando a qnt de baterias e ver oq acontece!
Depois venho dizer algo, valeu pela ajuda

Mortis

Você não tem um multímetro para medir as baterias e as saídas do drive? Nos post que te indiquei um colega reclamava de baixa tensão na saída, mas respondeu sobre resolução. Já é esperada uma pequena queda de tensão na saída em relação a entrada.

Eu tenho um drive similar, eu uso motores de 3 a 6 volts com baterias de 7,4v e não tive problemas (o meu é um pouco diferente do teu, mas aparentemente o mesmo esquema e componentes).

Osias Neto

você não tem uma fonte de parede só para testar (tipo de notebook por exemplo)? ou uma bateria de maior corrente, 2000mA.h por exemplo? Muitas vezes consideramos a tensão e esquecemos da corrente do circuito que é crucial para o funcionamento.

futepa

eu consegui resolver, as baterias, apesar de enviarem a voltagem necessaria, não tinha tensão suficiente. eu peguei um multimetro de um amigo e vi q o motor tinha resistência de 2ohm, logo a amperagem que minhas pilhas entregavam era pouca, e o drive ainda reduzia mais. Com uma fonte de parede deu td certo.

Brigado ai vcs!

HugoPT

Quote
apesar de enviarem a voltagem necessaria, não tinha tensão suficiente

Querias dizer corrente.
Inda bem que resolveste o teu misterio e nao desististe.
Bons estudos
Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B

Go Up