Pages: [1] 2   Go Down
Author Topic: chiarimenti su funzionamento relè  (Read 848 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao!
mi sono cimentato per la prima volta a costruire un circuito con un relè (la mia intenzione è quella di inserirmi alla presa di casa da 220V per poter controllare una lampada). Ho comprato un relè con resistenza interna di 68 ohm, possibilità di carico fino a 220-230V, 5A e con la bobina che viene eccitata a 6V e consuma 100 mA. Ho seguito poi questa guida per essere sicuro di non fare danni http://www.logicaprogrammabile.it/come-pilotare-rele/
Dopo aver effettuato un paio di calcoli per adattare la guida alla mia situazione, ho costruito il circuito, che però non funziona.
Infine accidentalmente (effettuando una misurazione sbagliata) ho scoperto che togliendo le resistenze il circuito funziona!!! anche se non capisco perché...  smiley-cry
qualcuno sa spiegarmi perché funziona quando "sulla carta" non dovrebbe?
anche perché ho provato a misurare la corrente in uscita dal pin dell'arduino, e il tester mi da 70 mA, ma, correggetemi se sbaglio, l'arduino UNO dà al massimo 40 mA in uscita da un pin...
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Il relè come lo alimenti?
Puoi postare lo schema che hai fatto?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Il relè come lo alimenti?
Puoi postare lo schema che hai fatto?

il relè è collegato al pin da 5V dell'Arduino.. come anche l'alimentazione da 3,3 V del led..


* IMG_20130522_112728.jpg (229.23 KB, 1080x792 - viewed 32 times.)
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Manca la resistenza sulla base del transistor.
Perchè usi i 3.3V per il Led?

http://forum.arduino.cc/index.php?topic=146152.0
Qui ci sono un po' di connessioni base, alla scheda 3 come collegare un relè.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Manca la resistenza sulla base del transistor.
Perchè usi i 3.3V per il Led?

è proprio quello il "problema".. se inserisco la resistenza non funziona più il circuito.. non capisco, funziona, ma non so il perché! smiley

il led l'ho collegato al 3,3V per comodità, non c'è un motivo specifico.. mi serviva un circuito di prova prima di collegarmi alla 220
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

è proprio quello il "problema".. se inserisco la resistenza non funziona più il circuito.. non capisco, funziona, ma non so il perché! smiley

Che resistenza hai messo?

il led l'ho collegato al 3,3V per comodità, non c'è un motivo specifico.. mi serviva un circuito di prova prima di collegarmi alla 220

Con quella resistenza (1KΩ) puoi collegarlo anche ai 5V.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Che resistenza hai messo?

inizialmente avevo messo una da 3Kohm più un'altra da 10Kohm che scaricava a terra (come nella guida che ho linkato all'inizio).. la seconda non so bene a cosa serva, mi sono fidato della guida
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Inizialmente avevo messo una da 3Kohm più un'altra da 10Kohm che scaricava a terra (come nella guida che ho linkato all'inizio).. la seconda non so bene a cosa serva, mi sono fidato della guida

Metti solo una resistenza da 3K tra il pin e la base del transistor.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Metti solo una resistenza da 3K tra il pin e la base del transistor.

ho già provato, nel momento in cui inserisco una resistenza tra il pin e la base, il circuito non funziona più.. ho provato anche ad inserire resistenze più piccole e più grandi, il risultato non cambia.. la cosa strana è che funziona anche se non dovrebbe.. ho anche provato a misurare le correnti di base e di collettore.. ib= 77 mA  e ic=70 mA...  che è assurdo! eppure funziona
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A questo punto mi arrendo  smiley-grin
Mi sembra stranissima la cosa, attendiamo il parere di qualcuno più esperto.


PS) Per caso hai un'altro transistor con cui provare?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ahah smiley intendi un altro dello stesso tipo? adesso provo.. dici che potrebbe essere danneggiato quello che sto usando?
Logged

ivrea (to)
Offline Offline
Faraday Member
**
Karma: 75
Posts: 4599
miaaao ^-^
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mi sembra stranissima la cosa, attendiamo il parere di qualcuno più esperto.

Che non sono io  smiley-mr-green   , però leggendo il primo post di @edo,   sta usando un relè che può pilotare 220V con una corrente continua a 3,3V.
@pighi non può essere quello il problema?  @edo che caratteristiche ha il relè (datasheet) ?
Logged

my name is IGOR, not AIGOR

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Che non sono io  smiley-mr-green   , però leggendo il primo post di @edo,   sta usando un relè che può pilotare 220V con una corrente continua a 3,3V.
@pighi non può essere quello il problema?  @edo che caratteristiche ha il relè?

No, ha postato lo schema che sta usano ora ed è "formalmente" corretto a parte la resistenza cha manca
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ho provato ad usare un altro bc547b.. stesso risultato.. nel momento in cui inserisco una resistenza in serie, smette di funzionare
Logged

Italy
Offline Offline
Edison Member
*
Karma: 115
Posts: 1132
O ti distingui o ti estingui
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

ho provato ad usare un altro bc547b.. stesso risultato.. nel momento in cui inserisco una resistenza in serie, smette di funzionare

Curiosità mia. Non è che puoi postare una foto del tutto?
Logged

Pages: [1] 2   Go Up
Jump to: