Go Down

Topic: 3.2" TFT LCD Touch Shield for Arduino doesnt work with due (Read 5839 times) previous topic - next topic

Hello,

I recently bought a new LCD shield (http://www.robotshop.com/3-2-tft-lcd-touch-shield-arduino.html).

It is a SSD1289 controller (http://www.robotshop.com/content/PDF/3.2-tft-lcd-touch-shield-shd032.pdf)

I tried to use it with UTFT but it doesnt work. Screen is on (grey color).

I tried different settings like UTFT myGLCD(ITDB32S,38,39,40,41);

A slight change of screen color appears when I set ITDB32.

The only things that is working is the touch screen (using UTouch).

Thanks,
X.

Manualy configure the OUTPUT PINS
pinMode(CS, OUTPUT)...
Do that for all pins AFTER initializing =]
(Had the same problem, and took me 72hours without sleeping to figure out it)
Arduino DueTimer | https://github.com/ivanseidel/DueTimer
Arduino Thread | https://github.com/ivanseidel/ArduinoThread


Manualy configure the OUTPUT PINS
pinMode(CS, OUTPUT)...
Do that for all pins AFTER initializing =]
(Had the same problem, and took me 72hours without sleeping to figure out it)


Hello ivanseidel,

I tried it and it works fine !

Code: [Select]
// Setup the LCD
  myGLCD.InitLCD();
// add support to ITead shields
  pinMode(38, OUTPUT);
  pinMode(39, OUTPUT);
  pinMode(40, OUTPUT);
  pinMode(41, OUTPUT);


Thank you very very much !  :)

Bye,
X.

rmohan10

#3
Jul 11, 2013, 06:57 am Last Edit: Jul 11, 2013, 07:03 am by rmohan10 Reason: 1
Hi, I have womart 3.2TFT and I was trying with Arduino Mega and facing same problem of blank white screen (there is no flickering etc just white blank screen).

Going through various posts here I tried ITDB32, ITDB32S, SSD1289, SSD1289_8 etc still no use not working.

I can not suspect the TFT because I got this tested when I bought it in Shenzhen market (yes, I bought this when I visited China but could not get any other information form the shop owner - Need to know Chinese!!).

The module I bought looks as attached.

In the previous post it was mentioned to set the pin mode explicitly. In which version of UTFT it was done?

The reason I am asking is that I am that the below lines are there in the UTFT.cpp in version 2.42   17 Jun 2013
Code: [Select]
}
pinMode(RS,OUTPUT);
pinMode(WR,OUTPUT);
pinMode(CS,OUTPUT);
pinMode(RST,OUTPUT);


Just to add : The module I bought is shown in website http://www.womarts.com/?product-105.html

Regards,
R.Mohan

Same Problem with me. Arduino Mega with 3.2 Womart shield. Its giving me white screen with UTFT library.

Any update on the problem?


JSSSpace

I have the same problem with a Mega  working with a Womarts 3.2 TFT. I get a white screen. Any help would be appreciated.

JSSSpace

I have added in the following code

UTFT myGLCD(ITDB32S,38,39,40,41);   // Remember to change the model parameter to suit your display module!

void setup()
{
  randomSeed(analogRead(0));
 
// Setup the LCD
  myGLCD.InitLCD();
// add support to ITead shields
  pinMode(38, OUTPUT);
  pinMode(39, OUTPUT);
  pinMode(40, OUTPUT);
  pinMode(41, OUTPUT);


I get the following error:

UTFT does not name a type. I have tried various entries for the board type in place of ITDB32S with no change in the error or in the TFT behavior. I think that we do not have the type right. Anybody have any ideas?


MarkT

Code: [Select]
#include <UTFT.h>??
Installed UTFT library in the right place?
Then quit and restarted Arduino software?
[ I won't respond to messages, use the forum please ]

JSSSpace

Thanks for your help. That fixed the compiler issues and the software code loaded. However, I still have blank screen - white. I still do not think I have right type but do not see Womart referenced in documentation. Any more suggestions?

Sepius

I have the Womarts type as pictured above, red board where the display is on the shield (making it difficult to ID any of the components).
Change the type to SSD1289, this works for me (along with the other recommendations in this post).

Extract from the data sheet from the OP.
The Arduino 3.2" Touch shield uses the SSD1289 controller , it support 16bit
data interface. The touch IC is XPT2046.

vmansmx5

Hi there guys I have used the shield with the mega and due
for start these displays only work at 3.3 v well the specs say 2.8v
on the mega it runs at 5v so the shield needs 10K resisters on the signal tracks to the display DB0 to db15
for the due remove the resisters and put links there the due runs at 3.3 volts

Anyone be able to operate womart 3.2 tft ? ... so far with every option available I am unable to get this thing working.
Tried all the models in hennings library. Fail !!

Is the issue with board having resistors to convert 5V to 3.3v ?

Regards!

finally get it managed to work. Its actually 3.5 inch tft and driver is R61581  :D, its available in new UTFT by hennings.

However SD and Touch still not working  =(

Go Up