Pages: 1 [2]   Go Down
Author Topic: GSM Shield weired characters in SMS  (Read 7852 times)
0 Members and 1 Guest are viewing this topic.
Madrid (Spain)
Offline Offline
Full Member
***
Karma: 0
Posts: 137
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!,

I find the “CSMP” not right due to this issue.
CSMP’s dcs setting is 8, which means this is in UCS2  coding, but the CSCS using “GSM” coding. Here is the conflict.
 
Just set AT+CSMP=17,255,0,0 first,then try to send SMS again..
 
If you have any doubt, reply this post.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,

I am glad that you still find new ways for me to try.
however even after following your instruction (see below) I am getting the same result (when sending "test" I am getting "瑥獴" as string within the sms).

any other ideas that i could try?
thanks a lot!!

Code:
Start commands...
Start Reset
End Reset
Ready for commands...
AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CMGF=1%13%%13%%10%
OK%13%%10%
AT+CSMP? %13%%13%%10%
+CSMP: 17,255,0,8%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP=17,255,0,0%13%%13%%10%
OK%13%%10%
AT+CSMP?%13%%13%%10%
+CSMP: 17,255,0,0%13%%10%
%13%%10%
OK%13%%10%
Logged

Madrid (Spain)
Offline Offline
Full Member
***
Karma: 0
Posts: 137
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try now changing character set to UCS2 with AT+CSCS="UCS2" and send any message. Post the results.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i followed your suggestion:

Code:
Start Reset
End Reset
Ready for commands...
%-8%AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSCS="UCS2"%13%%13%%10%
OK%13%%10%
AT+CSCS?%13%%13%%10%
+CSCS: "UCS2"%13%%10%
%13%%10%
OK%13%%10%

unfortunately there is no change in behavior.

message string "test" still leads to "瑥獴" when receiving the sms

any idea on how to fix that?
Logged

Madrid (Spain)
Offline Offline
Full Member
***
Karma: 0
Posts: 137
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Sorry, I forget to say you that you have to save CSCS configuration with AT&W.

1 - Change CSCS with: AT+CSCS="UCS2"
2 - Save with: AT&W
3 - Restart modem and check that it is saved with: AT+CSCS?
4 - Send SMS!!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!

Your suggestion ("save" before restart) had some impact but not the desired one.
Here is the output that I gathered from serial output
 
Code:
Start Reset
End Reset
Ready for commands...
AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSCS="UCS2"%13%%13%%10%
OK%13%%10%
AT&W%13%%13%%10%
OK%13%%10%
Start Reset
End Reset
Ready for commands...
%-8%AT+CSCS?%13%%13%%10%
+CSCS: "UCS2"%13%%10%
%13%%10%
OK%13%%10%

Then I sent out some sample SMS via "send SMS" example code and got "completed" message.

Code:

SMSMS Messages Sender
GSM initialized
Enter a mobile number: +49151???????
Now, enter SMS content: SENDING

Message:
test

COMPLETE!

Unfortunately none of them arrived.

Then I changed back to GSM (AT+CSCS="GSM") and I got again the "old" erroneous behavior (receiving weird asian characters in the sms).

I also made sure that I followed your previous suggestion (AT+CSMP=17,255,0,0) but without any impact.

Any more ideas?
Logged

Madrid (Spain)
Offline Offline
Full Member
***
Karma: 0
Posts: 137
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Check if AT+CSMP=17,255,0,8 and try again with AT+CSCS="UCS2" saving with AT&W.

If not working, try AT+CSMP to 17,71,0,0 and AT+CSCS="GSM".
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi!

First run with UCS2

Code:
Start Reset
End Reset
Ready for commands...
%-8%AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSMP=17,255,0,8%13%%13%%10%
OK%13%%10%
AT+CSCS="UCS2"%13%%13%%10%
OK%13%%10%
AT&W%13%%13%%10%
OK%13%%10%

With the settings above (UCS2) SMS do not go through at all (sample sms-send program gives COMPLETION message).

Now checking previous settings and then second run with GSM

Code:
Start Reset
End Reset
Ready for commands...
%-8%AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSMP?%13%%13%%10%
+CSMP: 17,255,0,8%13%%10%
%13%%10%
OK%13%%10%
AT+CSCS?%13%%13%%10%
+CSCS: "UCS2"%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP=17,71,0,0%13%%13%%10%
OK%13%%10%
AT+CSCS="GSM"%13%%13%%10%
OK%13%%10%
AT&W%13%%13%%10%
OK%13%%10%

SMS goes through with GSM but the show erroneous characters and are unreadable.

Do you have any other ideas?

Btw: Anybody else using GSM shield in Europe (especially Germany) with T-Mobile provider? I am interested in seeing what your settings are for
AT+CSCS? and AT+CSCS?

Thanks
Musterstrasse
Logged

Madrid (Spain)
Offline Offline
Full Member
***
Karma: 0
Posts: 137
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Try this AT commands sequence:

1. AT+CSCA?

2. AT+CSMP?

3. AT+CSMP=17,255,0,0

4. AT+CSAS=0

(Reboot your Arduino + shield)

5. AT+CSMP? for check if 17,255,0,0 has been saved. If it done, send a SMS.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi davidgoth,

That was it. You fixed it.
I do now receive SMS in correct character set ("test" stays "test" on the receiving side).

Thanks a lot for taking care!

Best Regards,
Musterstrasse

P.S.: For anybody interested here is the output in serial monitor when following through your commands:

Code:
AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSCA?%13%%13%%10%
+CSCA: "+491710760000",145%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP?%13%%13%%10%
+CSMP: 17,255,0,8%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP=17,255,0,0%13%%13%%10%
OK%13%%10%
AT+CSAS=0%13%%13%%10%
OK%13%%10%
AT&W%13%%13%%10%
OK%13%%10%
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi davidgoth,

That was it. You fixed it.
I do now receive SMS in correct character set ("test" stays "test" on the receiving side).

Thanks a lot for taking care!

Best Regards,
Musterstrasse

P.S.: For anybody interested here is the output in serial monitor when following through your commands:

Code:
AT+CPIN=1234%13%%13%%10%
+CPIN: READY%13%%10%
%13%%10%
OK%13%%10%
%13%%10%
Call Ready%13%%10%
AT+CSCA?%13%%13%%10%
+CSCA: "+491710760000",145%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP?%13%%13%%10%
+CSMP: 17,255,0,8%13%%10%
%13%%10%
OK%13%%10%
AT+CSMP=17,255,0,0%13%%13%%10%
OK%13%%10%
AT+CSAS=0%13%%13%%10%
OK%13%%10%
AT&W%13%%13%%10%
OK%13%%10%



Mr.Musterstrasse

Couldyou share the program code for sending SMS after fix it

( I have the same problem  smiley-cry and I'm beginner in arduino )

Thanks smiley-kitty
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 22
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dear Nos-Al7arbi,

I am using the official "SendSMS Example" from Arduino.

See "http://arduino.cc/en/Tutorial/GSMExamplesSendSMS" and scroll down to the bottom.
This code along with the hint on how to change character set described in this post worked out for me.

Cheers,
Musterstrasse
Logged

Pages: 1 [2]   Go Up
Jump to: