Pages: [1]   Go Down
Author Topic: Problem, Error While Upload to iTead iBoard  (Read 1449 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have this problem while trying to upload a sketch to an iTead iBoard.  I am a noob that bought both an arduino uno kit and the iboard.

I have been able to program and upload to the uno with no issues so far.

I get the following error while trying to upload to the iboard.  I have tried the same code that has loaded into the uno.
Code:
avrdude: stk500_getsync(): not in sync: resp=0x00

A quick google search told me it is a communication error with the board.  Possibly that I am selecting the wrong board.  I have selected "Arduino Duemilanove w/ ATmega328" based on suggestions from the internet.  I have tried others just for good measure.

I have checked my serial connection and believe that the drivers are properly installed.  Unlike the uno kit, the iboard requires their FOCA programmer to interface with the board.  I show the driver provider as FTDI. 

I also tried changing the buad rate in the the device hardware section for the port.

I don't know what else to try.  Any suggestions are welcome.
Logged

Global Moderator
Boston area, metrowest
Offline Offline
Brattain Member
*****
Karma: 548
Posts: 27386
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Burn a known bootloader into the microcontroller?
Or, keep guessing until you find one that works.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

0
Offline Offline
Jr. Member
**
Karma: 1
Posts: 70
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

1. You need to make sure that you have installed the right driver for the FTDI chip or our FOCA board - if you can find the port in the IDE, there should not be any problem.

2. You should choose the "board" - > "Arduino Dumilanove or Nano w/ ATmega328" instead of the "Arduino UNO" - because the bootloader in IBoard is not UNO'
Logged

Itead Studio - Make innovation easier

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Update.  It looks like its my FOCA board.  I borrowed a friends and was able to upload a sketch with no problems.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just got another one off of amazon because I didn't want to wait for the one to come in from iTead all the way from China.  It is giving me the same error!  Seriously iTead, WTF?  I know its not a process issue as my friends borrowed FOCA still works fine.
Logged

Pages: [1]   Go Up
Jump to: