Go Down

Topic: winznet w812mj serious problems (Read 637 times) previous topic - next topic

ChrisS

Dear Community,

my friend and i have bought the wiznet w812mj Ethernet modules.
We have the same Problem to get it work.

We've wired the Module:
/SCS > Arduino D10
MOSI > Arduino D11
MISO > Arduino D12
SCLCK > Arduino D13

we are using 3,3V Powersupply (fixed Voltage regulator), to power the Ethernetmodule.

we also wired GND from Module to Arduino.

If we connect the Module to Lan we get a xp connection message.
100Mbit. 10Mbit too, if configured manually.

BUT WE CAN'T PING IT, DEMOS/EXAMPLES DOESN'T WORK.

Via PING there are 100% Timeouts,
DNS Resolve Example tells every time the same garbage IP ...

We think we've wired correctly, and have the same Bug.

Distance is 500 Kilometers so we tryied seperatly...

We have a serious Problem to get it work...
Please help!

Would be nice....

Greetings ChrisS
Sturmfabrik - mediale Dienstleistungen
www.sturmfabrik.de

ChrisS

*push*

Hope somebody can give us a hint!

Nothing is working yet.

Sorry for push, but posting time was very destructive.
(I will not push this post again.)

Greetings ChrisS
Sturmfabrik - mediale Dienstleistungen
www.sturmfabrik.de

Bryan

#2
Apr 15, 2010, 01:04 pm Last Edit: Apr 15, 2010, 01:11 pm by Bryan Reason: 1
I've some experience with the 811mj - differences being pin distance and some minor features - for ethernet connection.
I remember I had difficulties with pinging also.

Just in case you did not have a chance to look at the DHCP libray,
you may well have a look at the thread
(Arduino Forum - Wiz811MJ with Arduino for ethernet connection) including
DHCP library(credit: Jordan Terrel, http://blog.jordanterrell.com/post/Arduino-DHCP-Library-Version-04.aspx).
Spinlock's suggestions in the thread regarding ip address designation method was also a great help for the situation.

Hope this will help the situation.

ChrisS

Thank you for posting.

I soved the problem...

Lenght of wires have been  the cause.

I reduced the lenght of mosi miso s.o. now everthing works fine.

Hope with this i could help someone in the future.

Thank you!
Greetings ChrisS
Sturmfabrik - mediale Dienstleistungen
www.sturmfabrik.de

Bryan

#4
Apr 16, 2010, 09:46 am Last Edit: Apr 16, 2010, 09:47 am by Bryan Reason: 1
Glad to hear that you've solved it.

btw,if you don't mind, would you give me some hint regarding the length that caused the problem, just for future reference?

I might run into the same problem since I'm a newbie in this area.

Happy Arduinoing!
Bryan

ChrisS

mmh, tried with about 15cm signal wire lenght... because i used 2 Boards... one with arduino... one with modul.

Problems occur.

Now i have redone on one Board... Module and Arduino are sitting sidebyside... signal wire lenght is now about 5 cm.

Everything is working fine...

Many people forget to solder gnds down.... that improves working behaviour.

So... many unsed pins are solderd to GND.... don't forget that...
more than the half of pins have to be GND...

Greetings
ChrisS
Sturmfabrik - mediale Dienstleistungen
www.sturmfabrik.de

Bryan

#6
Apr 17, 2010, 10:46 am Last Edit: Apr 17, 2010, 10:48 am by Bryan Reason: 1
Hi, ChrisS.

By pure chance, I have connected my Arduino to the Wiznet using 7cm jumper cables.

If I had used longer ones, I could have fallen into big troubles.

I really appreciate your comments.

Bryan

Go Up