Go Down

Topic: Xbee Setup (Read 8510 times) previous topic - next topic


Yes I did that and got the following...





Ill Mill

Hmm its a little different format than mine prolly because your using pro.
Do you know if those responses match the 16bit address of your remote xbee? You can check if you read the remotes modem parameters. it should be under Addressing (SH Serial High, and SL serial Low)

If those numbers match then its not making sense why it isn't printing anything out. It seems to be communicating correctly.

There might be a quirk with the modules that your using that are different than the ones im using. If I think of anything Ill let you know. Its probably going to be something simple we are both missing.


Yeah I checked the 16bit addresses and they did match for both of the modules, yeah please let me know if you think of anything else...Thanks again for all the help, I'm doing this for a school project and have been stuck for a good couple of weeks.

Ill Mill

Yeah no problem, Ive been there with the school projects.

Its wierd that you are recieving 00 hex in X-ctu. That is NULL. Im still going back to hooking the Dout pin to an arduino's RX pin and trying to view the incoming data that way. I think it should work because a logic level high I think is 3V. Just don't hook it up with the TX going directly to the Xbee. Im not sure however if you will need to take the Atmega chip out or not. Try just plugging the arduino board in and starting the Arduino software then going to the serial port. Make sure the arduino IDE is set to 9600 baud. Then plug the DOUT into the RX.

I tested the code you were using last night and it came accross fine on my computer. I havn't tested it with the setup described above however, and I won't be home to test it for about 9 hours.

Let me know if your going to try this. You might just get a bunch of random crap if the voltage out of the xbee isn't high enough. Im learning as we go as well.


I've tried your idea with connecting the DOUT pin to the arduino and it did not print anything.  Someone suggested trying to use hyperterm instead of XCTU so I am going try that tonight and see if I can get anywhere with that.


So I finally got the Xbee to work, the problem was in the Xbee Explorer board I was connecting to the arduino with, thanks for the help before though.


What was the issue with the explorer board?  I'm waiting on a pair of 900's as well and want to have any kinks worked out ahead of time haha.  Did that tutorial posted earlier work out?


Arduino 0018 - Serial problems

I have had terrible problems trying a simple loop back test with xbee to xbee via an arduino.

I found an article that suggested a problem in the serial routines of 0017 so I figured the same problem in 0018.

The solution is to replace the Serial.begin() from the HardwareSerial.cpp of 0016

here it is save you hunting for it ... and everthing now working for me!!

void HardwareSerial::begin(long speed)

*_ubrrh = ((F_CPU / 16 + speed / 2) / speed - 1) >> 8;
*_ubrrl = ((F_CPU / 16 + speed / 2) / speed - 1);
 sbi(*_ucsrb, _rxen);
 sbi(*_ucsrb, _txen);
 sbi(*_ucsrb, _rxcie);



Apr 02, 2010, 09:01 pm Last Edit: Apr 02, 2010, 09:06 pm by farmer Reason: 1
I have the same issue with xbee 900 and a explorer board... would love to hear your solution.

I recieve hex 00 in x-ctu, but sending from x-ctu works, the xbee receives whatever x-ctu sends.
sometimes it also works with two terminals... that drives me crazy!


I had problems with two xbee using 0018.

Serial.print just seemed to send numbers instead of asci characters.

Using the loop back test from x-ctu was most confusing. x-ctu always sent correctly, arduino #1 receieved correctly but things went wrong from there.

My post of  18.03.2010 shows the solution that worked for me but it doesn't tell you which file to change. It is cores/[board]/hardwareserial.h

Obviously you need to ensure that you have the correct serial speed. After altering the cores/[board]/hardwareserial.h everyting worked very easily even at 115k baud!

For me, I do now have two, three ++ xbee terminals connected to arduinos communicating between themselves and/or to the pc usb.

When I first hit the problem I updated the xbee firmware using x-ctu. It didn't seem to make a difference or solve the problem but I thought I should mention it.


Apr 19, 2010, 11:15 am Last Edit: Apr 19, 2010, 12:13 pm by farmer Reason: 1
James did not answer, but I probably found the issue in this thread:


now I wonder what i can do to circumvent this in my setup  :-/
the reason (probably?) it works one way in my system is, that for the pc-connected xbee i use the LilyPad Xbee board, and on the other (not working) side it's the explorer board


Sorry I did not answer before, do you have the explored connected to the arduino or the computer?


Apr 19, 2010, 02:57 pm Last Edit: Apr 19, 2010, 02:59 pm by farmer Reason: 1
I have the lilypad on the computer via an fdti-usb connector and it works as intended.

however, the explorer on an arduino does not work
I saw you posted on the sparkfun comments and assume you have the same issue using an xbee 900.

one solution would be to buy the pallax or adafruit module but I would prefer to keep the money to myself ;)
oooh... well too simple: I could switch the lilypad and explorer so the lilypad is the sender, because I'll use it as one way connection anyway


My problem was the xbee explored connected to the arduino did not work for some reason, it only sen out null data.  I instead got an xbee breakout boardroom connect the xbee to the arduinohttp://www.sparkfun.com/commerce/product_info.php?products_id=8276. Try this, it is a cheap solution that worked for me, i don't know why the xbee explored did not work.


I had the same, exactly as you described: only sending null values.

just tested it by switching the lilypad and the explorer: it works.
I assume it's what the people tell in the sparkfun forum: the explorer is too weak for pro or 900 xbee modules to let it send - receiving still works because it does not draw so much current

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131