Go Down

Topic: Arduino DUE with ITDB02 not working (Read 1 time) previous topic - next topic

cnc4you

Hi
I have problem. I was looking everywhere. I read all topics in this forum. I found 2 with this problem but solutions not work with my project.
My shield with 3,2TFT works very well with Mega but not working with DUE. I was load standard example Itead studio, im change the this line:
UTFT myGLCD(ITDB32S,38,39,40,41);
and add declarations manual about OUTPUTS.
but still not working.
Can you tell me what is diferents DUE and MEGA? Why working with Mega but not working with DUE?
Im sorry for my english.

Graynomad

Quote
Can you tell me what is diferents DUE and MEGA?

The main difference is that the Mega is 5v and the Due is 3v3, what does the display need?

______
Rob
Rob Gray aka the GRAYnomad www.robgray.com

cnc4you

#2
Jun 16, 2013, 08:22 pm Last Edit: Jun 18, 2013, 06:56 pm by cnc4you Reason: 1
I know about diferent voltage. I have switch to change voltage 5 or 3,3V. I switch to 3,3 and connect to Arduino Due. Im loading sample code from http://www.henningkarlsen.com/electronics/library.php?id=51
Code: [Select]

// UTFT_ViewFont (C)2013 Henning Karlsen
// web: http://www.henningkarlsen.com/w electronics
//
// This program is a demo of the included fonts.
//
// This demo was made for modules with a screen resolution
// of 320x240 pixels.
//
// This program requires the UTFT library.
//

#include <UTFT.h>

// Declare which fonts we will be using
extern uint8_t SmallFont[];
extern uint8_t BigFont[];
extern uint8_t SevenSegNumFont[];

UTFT myGLCD(ITDB32S,38,39,40,41);    // Remember to change the model parameter to suit your display module!

void setup()
{
 myGLCD.InitLCD();

 myGLCD.clrScr();
}

void loop()
{
 myGLCD.setColor(0, 255, 0);
 myGLCD.setBackColor(0, 0, 0);

 myGLCD.setFont(BigFont);
 myGLCD.print(" !\"#$%&'()*+,-./", CENTER, 0);
 myGLCD.print("0123456789:;<=>?", CENTER, 16);
 myGLCD.print("@ABCDEFGHIJKLMNO", CENTER, 32);
 myGLCD.print("PQRSTUVWXYZ[\\]^_", CENTER, 48);
 myGLCD.print("`abcdefghijklmno", CENTER, 64);
 myGLCD.print("pqrstuvwxyz{|}~ ", CENTER, 80);

 myGLCD.setFont(SmallFont);
 myGLCD.print(" !\"#$%&'()*+,-./0123456789:;<=>?", CENTER, 120);
 myGLCD.print("@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_", CENTER, 132);
 myGLCD.print("`abcdefghijklmnopqrstuvwxyz{|}~ ", CENTER, 144);

 myGLCD.setFont(SevenSegNumFont);
 myGLCD.print("0123456789", CENTER, 190);

 while(1) {};
}



Probably i must to change parts of code but i don't know where.

I was compare code examples for AVR and ARM i don't seen any difference:(  
I know that some people who works. I saw on You tube the animation from this sample.
On Arduino Mega is the same animation .

I wrote to ITEAD Studio and they reply to me the simple code working on Due.  I send this code to Henning Karlsen.  He was written to me the know about this end correct bugs i your library in version 2.42. We must waiting.


Yes, Its working now!! http://henningkarlsen.com/electronics/library.php?id=51
v2.42   17 Jun 2013   •   fixed a small bug in drawBitmap()
                               •        fixed a bug in the 16-bit Arduino Due drive

Go Up