Go Down

Topic: Uno passes loop-back test, but upload fails (Read 953 times) previous topic - next topic

aero_b

Good day,

My Uno is being difficult. I have been unable to upload the example code for "Fade" after days of attempts (ok, let's not be too dramatic: evenings of attempts). Here are some details:


  • Arduino Uno

  • Windows 7 and XP have been tried

  • 2 USB Cables have been tried (one of which is from an external HDD that works)

  • Turning off Comodo firewall and antivirus has been tried

  • The loop-back test works

  • "COM3" correctly selected

  • "Uno" correctly selected

  • Blink was pre-loaded and is happily blinking away

  • Error message: "avrdude: stk500_getsync(): not in sync: resp=0x00"

  • Behaviour: after "Compiling..." the "L" LED flashes as it does on reset, then the RX LED flashes 3 times, then I get the error. Occasionally, I think I see TX blink on the first (of the three) RX blink(s), but maybe I'm hallucinating. "Blink" continues running.



Are there other tests I could do? Could something be fried "out-of-the-box" (I did order this online from afar...)? Is there a check I haven't found on the fora and therefore haven't done?

Thanks for any assistance!

Louis Davis

Is this a genuine Arduino Uno?
If not, it might not have the Uno/optiboot bootloader.

Try one of the other board selections, like Duemilanove.

aero_b

I'm quite sure it's genuine; it's got all sorts of fancy printing (including the outline of Italy next to "Made in Italy"), and generally looks legitimate.

For good measure, I tried Duemilanove ATmega 328 and Nano ATmega 328. No improvement.

I see you're thinking hard though, and looking for clues in what I wrote! Is there any other info I could provide to help?

Coding Badly


Have you ever successfully uploaded anything to the board?

CrossRoads

Do you have anything connected to D0, D1 that could be interfering with USB comm's?

Select File:Preferences, and check Verbose Output for "Upload".
What shows when you try and upload?
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

aero_b

Coding Badly: No, I have not yet successfully uploaded anything. I'm just starting out and the first challenge I gave myself was to upload an example program that doesn't need any circuitry.

CrossRoads: My Uno is completely naked right now. I have already set my upload to verbose and get:

Quote
System wide configuration file is "C:\Program Files (x86)\Arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM2
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.


I'm inexperienced, but the "avrdude: Recv: <blank>" doesn't look good. If the board passes the loop-back test, what could be causing it not to transmit back (if that's what the message above is saying)?

Also: Could anyone tell me what the normal behaviour would be? E.g. "L" LED blinks on reset, then what happens?


I have a couple of friends who have Arduino boards. I might try borrowing one to see if the rest of my set-up is good. It's just that I've read other posts where people have exchanged the Arduino/bought another and still had the same problem! If I can try it for free with a known good board, why not, right?

Coding Badly

#6
Jun 16, 2013, 07:26 pm Last Edit: Jun 16, 2013, 07:28 pm by Coding Badly Reason: 1
"COM 3 " correctly selected

Using Port                    : \\.\COM 2  


Oops.

aero_b

Haha, not quite that easy! It just depends which computer I'm posting from at any given time  ;)

On my laptop it's COM3 (the only option) and on my desktop it's COM2 (COM1 being the other--incorrect--option). Good catch on my inconsistency though. It appears nothing obvious is coming to anyone's mind so I'll attempt to borrow another Arduino to play with this week and see if it's my board that's causing trouble.

Thanks for the help so far!

Coding Badly


For what it's worth, next on the list is the bootloader getting erased.  This can happen with older boards; a diode was added to eliminate the problem.  The solution is simple: re-burn the bootloader.

retrolefty



For what it's worth, next on the list is the bootloader getting erased.  This can happen with older boards; a diode was added to eliminate the problem.  The solution is simple: re-burn the bootloader.



The diode added with R3 boards was not because it caused bootloaders to be lost without one, but rather a different symptom that caused an uploaded sketch not to run until one manually pressed the reset button. Loss of bootloader code is one of those 'mystery symptoms' that has never been solved or explained, at least to my satisfaction.

I once asked here several years ago if anyone could demonstrate sketch code that could effect the bootloader such that then required the bootloader to be reburned, but nobody ever posted an example. Obviously people have reburned their bootloaders to get their boards functional again, but that doesn't solve how the problem is generated in the first place?

Lefty

Coding Badly


Shivansh

hello everyone,
I got the same problem...!!
My board was working fine before a day(in fact, before a few mins) it suddenly stoped uploading.
The TX light is not working after compiling..
Rx blinks..
I could not find out the problem..!!

*Arduino Uno R3
*Windows 7 , IDE 1.0.4
*(CORRECT PORT, DRIVERs, BOARD have selected.(not sure about the programmer option)

Go Up