Pages: [1]   Go Down
Author Topic: [SOLVED] Bluetooth Bee V2 + Arduino Uno R3 + Xbee Shield: AT mode?  (Read 527 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I'm struggling to enter AT mode, without success.

I have an Arduino Uno R3 equipped with an Xbee Shield which mounts a Bluetooth Bee V2.

As wiki says, I placed the module in AT mode (I assumed turning from left to right the 'AT mode' switch on it) while off, then plugging the usb cable to the PC and opening Arduino IDE Serial Monitor.

Lastly, I set baud rate to 38400 and text to "both NL & CR".

But I still can't enter AT mode: if I send 'AT' or other commands, I don't receive answer.

What am I doing wrong?

I assume that when wiki says 'USB Xbee converter' it means the emulation via software provided by drivers for the usb cable, or... don't tell me I have to buy something like this?

Thanks in advance for any reply, and sorry if I am too elementary.
« Last Edit: June 18, 2013, 06:58:19 am by luke_bonham » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I read here about a similar problem: the guy said he did short cable jumper from Bluetooth Bee Dout pin directly to Arduino Rx pin to make it work.

I don't know a thing about electronics, could you please explain me how can I do that?

Moreover, a tutorial on the Xbee shield I'm using says (Step 4) I should remove microcontroller from my Arduino board in order to enter AT mode.

Problem is: how can I remove it safely? It seems so strongly attached to the board and I'm afraid to break it.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I solved.

Before going on with what the wiki says, microcontroller has to be removed.

Use a very small screwdriver in order to do that.
Logged

Pages: [1]   Go Up
Jump to: