Pages: [1]   Go Down
Author Topic: launch4J error  (Read 467 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was trying to create a lib file with some basic functions when something went wrong.  Just FYI I clicked on Add Lib and then nothing worked. I tried to restart Arduino but now all I get is "launch4J" error. I tried to delete Arduino and all it's sub folder but windows reported it could not delete the folders. I see all my folders have the Read-only flag set, I can't reset them. In my arduino directory there is a folder named "Libraries". That folder contains 20 layers of folders named the same thing all appears to be empty. Can't delete them. Windows reports the source file names are larger than is supported by the file system.
Searching the forum I found the command to run debug and generate a report the following is a copy of that report:

CmdLine:   C:\Users\PEH\Documents\Arduino\arduino-1.0.5\arduino.exe --l4j-debug
WOW64:      yes
Working dir:   C:\Users\PEH\Documents\Arduino\arduino-1.0.5\.
Bundled JRE:   java
Check launcher:   C:\Users\PEH\Documents\Arduino\arduino-1.0.5\java\bin\javaw.exe (OK)
Add classpath:   lib\pde.jar
Add classpath:   lib\core.jar
Add classpath:   lib\jna.jar
Add classpath:   lib\ecj.jar
Add classpath:   lib\RXTXcomm.jar
Launcher:   C:\Users\PEH\Documents\Arduino\arduino-1.0.5\java\bin\javaw.exe
Launcher args:   -Xms128m -Xmx128m -classpath "lib;C:\Users\PEH\Documents\Arduino\arduino-1.0.5\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base
Args length:   184/32768 chars

running windows 7

Any help, thanks
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This looks like a true arduino created problem. I could never delete the libraries folder even using a different operating system. So i moved it to the desk top and was then able to delete the arduino folder remaining in mydocuments. In the folder I moved to the desk top I was able to move the last two folders from the bottom of the tree to the desk top. The remaining folders were then deleted. Still can delete the libraries folder the system reports the name is too long for the file system. Additionally if I tried to move the last folder in the tree to the desk top I received a security warning alert.

As for the load error it appears that arduino likes to open a directory in mydocuments with a folder named libraries "..\mydocuments\arduino\libraries" when it can't do that you get the load error. By moving the folders to the desk top and deleting the arduino folder  from the mydocument directory the arduino program could create a new folder and sub directories as required and now loads.

Some day I will figure out how to remove the file I now have on my desk top.

Logged

Pages: [1]   Go Up
Jump to: