Go Down

Topic: avrdude burning bootloader issue with SMD ATMEGA 32 TQFP - stand alone arduino (Read 1 time) previous topic - next topic


Hi All,

I have made a standalone Arduino with a smd atmega 32 tqfp with 22pF caps and 16 MHz xtal etc.
Basically it's the same component setup that's done for the DIP version on a breadboard (including a 0.1 micro Farad cap on the reset line for auto reset when uploading a sketch).

I'm using the Ladyada USBTinyISP (V 2) to try and burn the bootloader, but am getting "avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check."

I've checked the connections with a continuity tester beep using a multimeter etc and double checked the SPI hookup referencing http://arduino.cc/en/Reference/SPI and the datasheet link  here: http://www.mouser.com/Search/Refine.aspx?Keyword=556-ATMEGA328P-AUR

I'm powering the circuit with it's own 5v separately via wall plug.
The USBTinyISP's 6 pin output cable header (with the red cable indicator as '1' in the 6 pin config) is connected to MISO (pin 16 = D12), MOSI (pin 15 = D11), SCK (pin 17 = D13), Reset (pin 29 = reset) and the ground to the circuit ground.

I've selected USBTinyISP as the programmer and 'Arduino Pro or Pro Mini (5V, 16 MHz )w/ ATmega328' as the board.
I tested the USBTinyISP itself and it burns the bootloader with no problems on a standard factory made Duemilanove.

I also tried uploading with the reset from the USBTinyISP connected to the reset line without the 0.1 uF cap with the same error.

I'm using Arduino IDE 1.0.1,
OSX 10.5.4

Any pointers greatly appreciated!

Thanks, Rich.


HI All - Solved.

For anyone else who might be experiencing a similar issue, it really does come down to checking the connections. This isn't just checking that the wires' connectivity is solid and complete (which is was in this case) but trying different places to connect to on the same traces.

I was powering the circuit separately from the USBtinyISP, which works fine on production boards, but not for my setup. I solved the problem by directly soldering female connectors onto these traces next to the TFQP chip:  +5 VDC , GND & Reset (on the chip side of the 0.1 uF cap), then added a jumper to the USBtinyISP, so that I could power the chip directly & the bootloader uploaded fine. Pin 13 blinks an LED.

In retrospect, perhaps the circuit wasn't grounded properly or the reset didn't go low because of the external supply (even though I tried different configurations) only with soldering the connectors mentioned did it work.

Hope this helps someone else.


Go Up