Pages: [1]   Go Down
Author Topic: Hulp gevraagd:avrdude: stk500_getsync(): not in sync: resp=0x00  (Read 2260 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Going faster than the speed of light isn't possible. That would mean you could go to a place in time. And at that time you wouldn´t be born, but still would be at that place.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sinds vorige week donderdag heb ik mijn eerste arduino (UNO 3) in mijn bezit. En na er wat mee gespeeld te hebben, kan ik sinds gisteren geen codes meer op de arduino zetten. Bij het erop willen zetten van de code krijg ik de volgende foutmelding "avrdude: stk500_getsync(): not in sync: resp=0x00"

Het lijkt een veel voorkomend probleem en ik heb dan ook van alles geprobeerd. Meestal schijnt het loskoppelen van de arduino resetten etc te werken. In mijn geval dus niet. Ook heb ik geprobeerd de loopback test uit te voeren. Maar ik krijg geen resultaat.

Ik werk met twee pc's, 1tje met wind 7 ultimate en de ander home premium. Heb de hele arduino software ook al opnieuw geinstalleerd.
Verder heb ik de juiste poorten ingesteld staan, juiste board. En de usb kabels zitten er goed in. Verder krijgt de arduino ook gewoon stroom en lijkt de reset te werken. Tevens werkt de laatste code die ik er opgezet heb ook nog gewoon. (code uit getting started with arduino, om een led met een drukknop aan en uit te zetten)

Verder heb ik met een multimeter nog gekeken naar de uitvoerspanningen van de arduino, en deze kloppen gewoon. (dus 5v geeft ongeveer 5v en 3.3 v geeft 3.3v).

Ik was bezig met het aansluiten van deze lcd. Vervolgens de arduino aangesloten op de pc, code willen uploaden en toen begon het. Weet bijna zeker dat ik geen kortsluiting gemaakt heb. Helaas heb ik de opstelling al opgeruimd dus ik kan er nu ook niks meer aan zien/laten zien.

Ik hoop dat er iemand een oplossing heeft/tips om het op te lossen.

Alvast bedankt
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 51
Posts: 1729
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Heb je al geprobeerd wanneer je de upload start, op reset van je Uno te drukken ?

Als je in de IDE de serial monitor start, reset je UNO dan ?

Als het antwoord op vraag 2 "nee" is, en het resetten direct na het starten van de upload niet helpt, dan lijkt het er verdacht veel op dat er iets mis is met je USB / seriaal omzetter op de UNO.
Wanneer die omzetter kapot is, kun je mogelijk nog wel wat doen met een andere omzetter of een echte seriële poort.
Weet je nog aan welke pins je de LCD hebt aangesloten ?
Heb je testapparatuur (multimeter en/of oscilloscoop) ?
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Newbie
*
Karma: 0
Posts: 4
Going faster than the speed of light isn't possible. That would mean you could go to a place in time. And at that time you wouldn´t be born, but still would be at that place.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ik heb de inderdaad geprobeerd bij het uploaden op de reset te drukken. En ik heb gekeken naar de het starten van de serial monitor en het antwoord is inderdaad nee.

Ik heb de lcd aangesloten met deze afbeelding http://arduino.cc/en/uploads/Tutorial/LCD_schem.png en de juiste pinnetjes op lcd gezocht met behulp van deze datasheet. irobot.ntue.edu.tw/mcu/LCD/AppCircuit/LCDLM018L.htm

En ik heb een multimeter en een analoge scoop in mij bezit.

En wat hoe zou ik dat met een echte seriële poort moeten doen?

Bedankt voor de moeite alvast MAS3
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 51
Posts: 1729
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm het aansluiten van de LCD kan op veel manieren fout gaan.
Zo kun je bijvoorbeeld in plaats van de 5 volt, de 3.3 volt hebben aangesloten.
Die 3.3 volt werd gemaakt door de USB omzetter en wanneer je die verkeerd gebruikt, kun je m kapot maken.
Maar voor de UNO is dat niet meer zo, daar word een andere chip gebruikt en komt de 3.3 volt uit een eigen regelaartje.
En je hebt gezegd dat je nog 3.3 volt hebt.

Wanneer je je UNO van voeding voorziet, zou heel even een LEDje voor de seriële communicatie moeten knipperen.
Gebeurt dat ook ?
Dat zou een indicatie zijn dat je wel een vorm van communicatie hebt

Ik wilde je adviseren de UNO rechtstreeks te koppelen met een seriële poort, maar dat moet je niet doen.
De nivo's op een pc poort zijn anders dan de 5 volt die je op je UNO hebt en ik ben er niet helemaal zeker van dat dat geen verdere schade aanricht.
Daarom dus maar beter niet doen.
Je kunt voor een grijpstuiver een adaptertje kopen uit China die de nivo's aanpast, en voor een extra grijpstuivertje een die hetzelfde doet als de omzetter op het bordje (dus van USB naar serieel op het passende nivo).
Voor mezelf heb ik dat meteen gedaan toen ik de prijzen zag, maar ik heb inmiddels hier ook een hele berg van dat speelgoed liggen.
Zoals twee Arduino pro mini's die zelf dus geen omzetter hebben.
Maar goed.

Het kan zijn dat je USB omzetter defect is of om een of andere reden zijn programma kwijt is.
In het laatste geval kun je dat wel verhelpen, maar dan moet je m programmeren via zijn eigen ICSP aansluiting.
Dan heb je dus wat meer hardware nodig.
Wanneer je nog een Arduino zou hebben, kun je de ene gebruiken om de andere te programmeren (en zo te reanimeren als een programma fout de oorzaak zou zijn).

Ik kan je zomaar niets aanraden wat je zou kunnen doen om dit op te lossen met alle vertrouwen dat dat goed zal gaan, sorry.
« Last Edit: June 24, 2013, 02:18:14 pm by MAS3 » Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Newbie
*
Karma: 0
Posts: 4
Going faster than the speed of light isn't possible. That would mean you could go to a place in time. And at that time you wouldn´t be born, but still would be at that place.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

zodra ik de arduino aansluit op de computer gaat er inderdaad een ledje knipperen. En de de computer ziet de arduino verder ook wel. En de voltuitgangen werken idd nog.

Het was verder mijn allereerste arduino, dus reanimeren wordt het dan ook niet meer. En ik geloof dat ik wel een kennis heb die de hardware heeft om de arduino te programmeren via zijn ICSP aansluiten....
Verder zal ik ook nog maar even afwachten wat de leverancier zegt erover.


Bedankt voor de moeite MAS3, en mocht ik er achterkomen wat het is dan zal ik het ook vermelden
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 51
Posts: 1729
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je hebt het toch geprobeerd met alleen de UNO he ?
Niet dat je pins 0 en 1 ergens voor gebruikt / aangesloten hebt, want dat levert je ook problemen op.
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Offline Offline
Newbie
*
Karma: 0
Posts: 4
Going faster than the speed of light isn't possible. That would mean you could go to a place in time. And at that time you wouldn´t be born, but still would be at that place.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ik heb het inderdaad alleen met de uno gedaan. ik heb inmiddels ook antwoord van de leverancier en de arduino wordt gewoon omruilt
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 51
Posts: 1729
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nou das dan heel netjes van die leverancier.
Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Pages: [1]   Go Up
Jump to: