Go Down

Topic: Delay when running serial monitor on Windows (Read 1 time) previous topic - next topic

GregM

Running 1.0.5 and notice there is about a 8-10 seconds delay when clicking on the serial monitor.

I found this post which fixes the problem.
The post is from a few years ago - how come the fix hasn't been included in the latest version?

http://forum.arduino.cc/index.php?topic=46977.0

http://servicios.ried.cl/arduino/temp/rxtxSerial-2.2_fixed_2009-03-17.rar

BTW Works on Win8 as well.

Louis Davis

I think the patched version of RXTX  has been committed to the 1.5.x branch.

See here:
http://forum.arduino.cc/index.php/topic,141797.0.html

And here:
https://github.com/arduino/Arduino/commit/849af97ac10a0ad8c832d88ee461c321e4321fc1

GregM


GregM

I dont think its included in the nightlies yet. I tried the latest nightly but the problem is still there. I'll just use the new rxtx file in the meantime.

guy_c

#4
Feb 26, 2014, 12:56 pm Last Edit: Feb 26, 2014, 12:58 pm by guy_c Reason: 1

Running 1.0.5 and notice there is about a 8-10 seconds delay when clicking on the serial monitor.

I found this post which fixes the problem.
The post is from a few years ago - how come the fix hasn't been included in the latest version?

http://forum.arduino.cc/index.php?topic=46977.0

http://servicios.ried.cl/arduino/temp/rxtxSerial-2.2_fixed_2009-03-17.rar

BTW Works on Win8 as well.



Could you please detail how to fix (minimize) this delay?
Thanks in advance for your time

Go Up