Go Down

Topic: RISOLTO Arduino mega e tft lcd 7" con shield (Read 11090 times) previous topic - next topic

cico_32

Jun 26, 2013, 11:52 pm Last Edit: Jun 27, 2013, 09:11 pm by cico_32 Reason: 1
Ciao a tutti, mi è arrivato questo LCD TFT ma scaricando tutto quanto mi indica il venditore, ho acquistato anche lo shield apposito indicato dallo stesso venditore, mi visualizza solo strisce verticali.
http://www.ebay.com/itm/7-7-0-inch-TFT-LCD-module-Font-IC-800x480-SSD1963-arduino-DUE-MEGA2560-3-5-4-3-/111008432389?
Con arduino mega 2560 non riesco a visualizzare nulla, cosa devo caricare?
Grazie saluti

uwefed

Quale libreria usi e quale sketch di prova? Quale shiled di interfaccia hai comprato?
Ciao Uwe

cico_32

#2
Jun 27, 2013, 10:21 am Last Edit: Jun 27, 2013, 11:40 am by cico_32 Reason: 1
Ciao questo è lo shield acquistato http://www.ebay.com/itm/TFT-SD-Shield-for-Arduino-MEGA-2560-LCD-Module-SD-level-translation-2-8-3-2-DUE-/121057451964?

Utilizzo anche una batteria esterna da 9 v DC per alimentare l'arduino mega.
La libreria è UTFT.h, UTFT_CTE.h e SPI.h
Il programma che utilizzo è CTE70_800x480.ino

Se inserisco il TFT 7", il programma non carica sull'arduino mega e dà errore che mi dice che non trova la COM4, mentre se tolgo il TFT il programma si carica correttamente (sempre sulla COM 4).

Se invece metto un TFT da 3,2" e carico sempre lo stesso programma, si carica correttamente senza dare errore e, naturalmente si vede male mentre se carico il programma per il 3.2" si vede bene.

Qualche idea?

Grazie saluti

cico_32

Grazie lo stesso, ho risolto.
Il problema stava nell'alimentazione esterna dell'arduino mega, ho comprato una batteria nuova da 9 v che è risultata scarica.
Ho risolto con alimentatore 9 v 1,5 A.
Saluti

leo72


ho comprato una batteria nuova da 9 v che è risultata scarica.

O forse che l'hai scaricata tu collegandola a tutto l'ambaradan?  ;)
Le batterie da 9V forniscono molta poca corrente, siamo sul paio di centinaia di mAh: basta poco per svuotarla in fretta  ;)

david_fiucci

Salve ragazzi
anch'io ho comprato lo stesso touch screen, con il mega e la shield. Mi è arrivato due giorni fa e mi stavo impazzendo perchè non funzionava nulla.
Avevo gli stessi problemi : Se collego il monitor si stacca la connessione COM e il software non caricava.
Allora per il software bisogna mettere //model parameter.....  UTFT myGLCD(CTE70, 38, 39, 40, 41);
E per l'alimentazione esterna sto ancora provando, anche se ho già visto che con 10 V si accende, ma poi va in tilt perchè si scaldano i condensatori
del regolatore di corrente. Mi devo procurare un alimentatore come quello di CICO.
Una domanda: ma a che tensione massima si può alimentare mega? Cioè UNO va fino a 12V, anzi è consigliato se devi lavorare con le uscite PWM, ed infatti io così ho fatto e con UNO sono a posto, ma con MEGA non dovrebbe essere la stessa cosa?
Grazie a chi mi volesse erudire.
P.S. cico ma non è fantastico questo 7 pollici???????

cico_32

@david
si david è davvero bello....cmq con 9 V riscalda lo stesso il circuito anche se non da problemi.
Il venditore mi ha detto di usare una 7 V la cosa importante è l'amperaggio che non devi avere meno di 600 mAh.
Saluti

david_fiucci

Ciao Cico, ti volevo fare una domanda, rivolta a tutti naturalmente:
ho risolto il problema dell'alimetazione con un riduttore autocostruito, se volete posso postare il circuito, e funziona tutto bene, lo alimento a 7.2 V ma funziona già da 6.5V, ma è raccomandato per MEGA di non scendere sotto 7V. OK .
Ma il problema è che la scheda Mega si scalda da morire, anzi fuma proprio dopo due minuti, cioè si scalda lo stabilizzatore di tensione.

Ho visto che i condensatori sono 47 microfarad 16V e qui sta il problema: su UNO sono 47 microfarad 25V infatti io con UNO ci ho fatto di tutto senza problemi ma questo MEGA mi sta deludendo proprio. Perchè hanno messo i condensatori più piccoli????????????????????

Domanda: tu hai lo stesso problema? Hai provato a bypassare, per caso, la retroilluminazione del monitor? io ci sto pensando.....

probabilmente così si limita la corrente che passa dalla scheda, perchè Mega sopporta massimo 500mA e questo schermo da solo ne vuole 600, poi c'è la scheda, la shield e se vuoi metterci qualcos'altro come fai? se vuoi usare una porta PWM?
Ciao, a tutti naturalmente....

cico_32

Ciao David, a me scalda ma senza fare fumo....
Il fatto di dare un'alimentazione a parte della retroilluminazione non sarebbe errata come idea in modo da togliere assorbimento all'arduino.
Io ancora non lo tengo molto acceso perchè sto dedicandomi alla parte software del progetto per cui lo accendo solo per verificare ciò che visualizza...
Se fai il bypass fammi sapere se tutto funziona bene.
Saluti

ratto93

Potete caricare una oto diquesto schermo ? mi interessa l'argomento :)
Se corri veloce come un fulmine, ti schianterai come un tuono.

cico_32

Questo è il mio .....
saluti

ratto93

Se corri veloce come un fulmine, ti schianterai come un tuono.

david_fiucci

Allora ho trovato una soluzione al problema del riscaldamento (globale) del regolatore di corrente:

Si può saldare in parallelo, cioè sopra, con un po di attenzione, un integrato uguale, in modo che ognuno lavori alla metà del carico.
questo è il link del pezzo che è uguale a quello di arduino mega:

http://it.farnell.com/on-semiconductor/ncp1117st50t3g/ldo-reg-15vin-1a-5v-1-3sot223/dp/2112617?Ntt=NCP1117ST50T3G

In questo modo si può aumentare tutta la corrente in uscita dai pin, naturalmente attenzione a non esagerare altrimenti bruciate la scheda.

Attendo risposte anche molto critiche.
Qualcuno può dirlo a Michele Menniti? Lui è molto bravo.
Ciao

vinciolo

ammazza che spettacolo sto schermo...ma è quello touch o no?
anche io vorrei comprare questo(in realtà sono indeciso tra il 5" e il 7")

ma gli servo veramente tutti quei pin? quanti rimangono disponibili e quali?

io ho una mega 2560 alimentata a 9v e non si scalda per niente, si scaldava leggermente a 12v

cico_32

@vinciolo
Si lo schermo è touch.
Probabilmente non hai surriscaldamento della scheda perchè le correnti che gestisci sono bassissime.....anche io se tolgo il monitor non brucia nulla!!!!

Go Up