Pages: [1]   Go Down
Author Topic: Troubleshooting Due - won't connect to PC  (Read 429 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have a new-ish (one month or so) Due that was working yesterday, but today is not detected by the PC when I connect it to either the programming or native port. By "not detected" I mean that the arduino is not displayed when I run lsusb (Ubuntu linux) and there are no /dev/ttyACM* device files created. Likewise, there are no messages generated in /var/log/syslog when I plug/unplug the device. When it is connected, both the L and On LEDs are illuminated and no others. I have tried pressing reset, erase, and both; nothing seems to help.

Is this a Brickduino? Are there any other options for troubleshooting it?
Logged

Offline Offline
Jr. Member
**
Karma: 2
Posts: 61
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try a different cable.
Try powering down the linux machine.  I have had problems with the hardware on the PC side before where it has be completely powered off (unplug power cable from back of power supply or switch if you have it.)
Try both the Programming port and the native port independently.
What else do you have connected to the Due?  Try adding power to the 12V barrel jack.
Make sure you're reset switch is still switching and isn't being held in the wrong position.

Also make sure all the USB 3.0 vs 2.0 stuff isn't an issue (i.e. stay away from 3.0 smiley

Logged

Pages: [1]   Go Up
Jump to: