Go Down

Topic: HUD per arduino (Read 6495 times) previous topic - next topic

AleCune93

Subito volevo farla su una millefori.. ma poi si sovrapponevano i fili, e mi stava uscendo un pò un pasticcio.. Quindi ho provato cosi.. Considerando che l'ho fatto col "stira & ammira" è anche uscita benino..

AleCune93

Ok.. ecco un'altra novità.. Come se non bastasse tutto quello che c'ho messo dentro, (guardando iron man) mi è venuta in mente una nuova cosa da aggiungerci.. Un modulo che mi riproduca una voce in base a determinati eventi ricevuti da arduino.. Cosi da mettere degli altoparlanti all'interno del casco..!!
Cercando su google ho trovato un LPM11162.. è valido o è una ciofeca!?

lesto

inizia a finire questo.

per riprodurrei i suoni serve un chip esterno, vedi su sparkfun ci sono vari shield (con schemi open-source ed esempi con arduino), però quei chip iniziano a essere complessi per i DIY date le loro micro-dimensioni :)
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

Brunello

Quote
Un modulo che mi riproduca una voce in base a determinati eventi ricevuti da arduino.. Cosi da mettere degli altoparlanti all'interno del casco..!!


sai che bello sentirsi dire...
Livello benzina..... 7%
Livello benzina..... 4%
Livello benzina..... 2%
Benzina terminata.... il distributore piu' vicino e' a 6 km.


superlol


...
Benzina terminata.... il distributore piu' vicino e' a 6 km.
....

arduino questo non potrà mai farlo  :P
Il nuovo forum italiano sull'elettronica: http://www.electroit.tk/ <--- Nuovamente online!

lesto

perchè no, con una FPU esterna..
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

superlol

e tutta la parte di memorizzazione di tutti i distributori la fai tu? hackeri OSM (che da questo punto di vista non è perfetto..) o google maps?  XD
certo se avessi un bel poì di tempo da spendere va bene...
Il nuovo forum italiano sull'elettronica: http://www.electroit.tk/ <--- Nuovamente online!

lesto

perchè "hackeri" se le mappe sono open source? la ricerca è più semplice di quello che credi, specialmente se usi ua connessione dati e puoi appoggirti quindi ad un server fatto ad-hoc :)
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

AleCune93

Scusate il ritardo x la risposta.. week-end impegnativo con la ragazza XD

Comunque.. perchè necessito di una shield!? Quel modulo non va bene da solo!? Da quello che ho capito basta caricarci sopra i .wav e me li riproduce.. non è cosi!?

lesto

uno "shield" è semplicemente un modo pratico per collegare un chip esterno ad arduino: esso trasla i livelli se necessario, e generalemnte è plug-n-play: ti arriva, lo attacchi, carichi il codice e funziona.

Se tu usi il chip da solo in pratica ti stai costruendo tu la shield su breadboard o PCB o millefori, ma considerando che spesso i chip dalle funzioni complesse sono SMD..
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

AleCune93

Beh.. alla fin fine il LPM11162 ha i connettori strip.. quindi non è per niente difficile collegarlo ad arduino.. Piu che altro non so se è un modulo valido.. sicuramente ce ne sono di più complessi e migliori, ma per le cavolate che devo fare non so se è abbastanza..

AleCune93

Oggi ho montato il tutto eeeeeee.... non va  =(
Non va bene la parte della benzina.. Non arriva corrente al sensore.. Cioè, se io collego l'arduino mi escono 3,3v e mi tornano (nel pin del sensore) 3,3v.. Sembra quasi che non arrivi corrente al sensore..

Brunello

ma non s'era detto che il "sensore" era un potenziometro ?

AleCune93

Sinceramente devo ancora capire cos'è =(  In teoria si, è un potenziometro..
Però se io gli faccio arrivare 3,3v dovrebbe mandarmi fuori un valore inferiore in base alla quantità di benzina che c'è nel serbatoio.. Domani provo a rifare da zero i collegamenti, non vorrei aver sbagliato qualcosa.. Visto che ci sono cambio fili, e passo ad una circonferenza più grande..

Brunello

Quote
Non arriva corrente al sensore.. Cioè, se io collego l'arduino mi escono 3,3v e mi tornano (nel pin del sensore) 3,3v.. Sembra quasi che non arrivi corrente al sensore..


pare che l'altro capo del potenziometro non sia a GND

Go Up