Go Down

Topic: [SOLVED] My first Mini Pro, Atmega328 5v16M, Won't upload (Read 446 times) previous topic - next topic

Ashton

Jul 06, 2013, 04:06 pm Last Edit: Jul 07, 2013, 01:00 am by Ashton Reason: 1
I'm trying to get my first Mini Pro Atmega328 5v 16M module to operate, but I seem to be having a loading failure.
The power LED is on, and the Pin 13 LED is blinking, with the Blink sketch pre-installed I assume.
I'm receiving the "avrdude: stk500_getsync(): not in sync: resp=0x00" error and no load.  

I have verified my serial port's operation via loop test, and tried other mini pro models under Board select.  
I'm trying 9600 baud, same as used with a working Nano Atmega328 5v 16M module I have?

I have also tried connecting the Serial DTR to the Mini's GRN pin as found here: http://tutorial.cytron.com.my/2012/02/28/loading-program-to-arduino-promini/, but it didn't help.

Any suggestions appreciated.

LarryD


Have you looked at this?
http://forum.arduino.cc/index.php?topic=157482.0
The way you have it in your schematic isn't the same as how you have it wired up!

Ashton

I have solved this.

I had not found that post, but learned about the Reset switch use.

I found that the Reset button must be pressed before pressing the Upload, then release as the IDE begins displaying Uploading.
I also powered the Mini Pro from the serial adapter 5V power, that may or may not have helped.
Thanks

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy