Pages: [1]   Go Down
Author Topic: can't add a programmer to Arduino 1.0.3  (Read 306 times)
0 Members and 1 Guest are viewing this topic.
Hurley, NY
Offline Offline
Jr. Member
**
Karma: 0
Posts: 86
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I've tried editing programmers.txt in /hardware in the Arduino directory as well as /hardware in the sketch directory, but nothing I do changes the list of programmers available. I can tell my edits are having no effect since even editing the names of programmers that are present has no effect.  Is there some other super secret place where the programmer list is stored that I do not know about?  I'm using Arduino on Windows 7.  Changes to programmers.txt have immediate effects in Arduino 023 -- and because i can find my programmer there but not in 1.0.3, i've been reluctant to upgrade.
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 212
Posts: 8967
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

On my MacBook I edited:
/Applications/Arduino 1.0.5.app/Contents/Resources/Java/hardware/arduino/programmers.txt

The results of the edit were visible after I re-started the IDE.

I then tried creating the file:
/Users/john/Documents/Arduino/hardware/MyProgrammer/programmers.txt

After re-starting the IDE that, too, showed up under Tools->Programmer

Perhaps 1.0.3 has a bug.  I think 1.0.5 is the most current and that's what I use.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Hurley, NY
Offline Offline
Jr. Member
**
Karma: 0
Posts: 86
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hmm, the upgrade to 1.5.2 fixed my problem.  thanks!
« Last Edit: July 06, 2013, 07:20:51 pm by bigfun » Logged

Pages: [1]   Go Up
Jump to: