Pages: [1]   Go Down
Author Topic: Xbee no se asocia  (Read 1018 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas,

Tengo dos arduino uno, dos shields y dos modulos Xbee y estoy tratando de establecer comunicacion entre ellos. He configurado uno perfectamente, quitando el micro, modo USB y usando el programa X-CTU. Cuando intento hacer lo mismo con el segundo, X-CTU me muestra "Unable to communicate with the modem" y ademas el LED Associative no parpadea (el otro si lo hace). He probado con todas las velocidades y con el comando +++ en el Arduino serial monitor, y nada. Tambien he probado todas las combinaciones posibles entre placas arduino, shields y modulos Xbee, quedando claro que lo que falla es el modulo Xbee. Como soy nuevo en esto no se que mas hacer. Alguna idea? Gracias de antemano!!

Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola!
Hace un tiempo yo tuve problemas también programando Xbee's. Quizás te sirve verificar alguno de estos pasos:
1. ¿Has programado cada Xbee con la dirección remota a la que tiene que comunicarse? Ver el reverso de tu módulo.
2. ¿Has bajado el firmware más reciente?
3. ¿Estás programando cada módulo con la configuración pertinente? Por ejemplo como End Device y Coordinador.
En cualquier caso te recomiendo echar un vistazo a un tutorial de Opiron:
http://www.opiron.com/portfolio/todo-sobre-xbee-by-opiron
Saludos,
Logged


Offline Offline
Newbie
*
Karma: 1
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola TLERDRDEN, gracias por contestar.

El problema es que no puedo ni siquiera acceder a la configuracion de uno de los modulos Xbee, con lo que no le puedo meter ni la MAC ni el firmware ni nada. Y tampoco me deja hacerle un hard reset.

Un saludo!!
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola,
Vaya, entonces estas en problemas jeje, a mi se me estropeó uno hace un tiempo smiley-sad. Supongo que ya te has leído esta solución en la página de Digi: http://www.digi.com/support/kbase/kbaseresultdetl?id=320
¿Te ha funcionado? Por cierto, ¿habías usado el Xbee anteriormente? A mi se me estropeó cargándole un firmware y luego no pude recuperarlo.
Saludos!
Logged


Offline Offline
Newbie
*
Karma: 1
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas,

La verdad es que no lo habia mirado y, de hecho no se ni para que sirve, para reconfigurar los ports??

Nunca habia usado xbee, he empezado a trabajar en una empresa y ya me he encontrado los modulos asi, con lo que no se que les han hecho antes de entrar yo, xD. Puede que sea algo del firmware como dices tu, ya que aqui la conexion de internet es un asco y he tenido problemas a la hora de actualizarlo.

Un saludo!!
Logged

NZ
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

mientras cargaba el firmware a un xbee (xbee serie1) falló y nunca más lo reconoció el PC :-( hasta que lo resetié :-)
siguiendo los pasos:

• Place the module in the Digi interface board (o en el Xbee Explorer) connected to the PC running X-CTU.
• In the PC Settings tab, select the COM port, and set the baud rate there to 9600, no parity, no flow control 8 data bits and 1 stop bit.
• If the radio had API firmware in it, then check the Enable API box, otherwise, leave the box unchecked.
• Select your modem from the Modem drop-down menu in the Modem Configuration tab. Select the appropriate Function Set from the function set drop-down menu. Select the desired firmware version.
• Check the Always Update Firmware box.
• Click Write.
• The radio should begin to reflash firmware

de ser el mismo problema tu xbee debería revivir  smiley


edit: Cu'al Xbee est'as usando? serie1 or serie 2 ? para la serie 1 recomiendo usar el firmware 10C8
« Last Edit: July 21, 2013, 07:09:52 pm by f0raster0 » Logged

keep calm & carry on

Pages: [1]   Go Up
Jump to: