Go Down

Topic: werid error - No device found (Read 527 times) previous topic - next topic

ralphnev

been working on my second Due for 8 weeks or so 
suddenly i started getting No device found on COM5

i tried the Native port  & can program the device -
but the programming port seems to be kaput ..
Due #1 / the nano / & others work fine ...
tried to change to COM10  no effect ..

anybody seen this before?

ralphnev

#1
Jul 16, 2013, 02:04 pm Last Edit: Jul 16, 2013, 04:13 pm by ralphnev Reason: 1
reply to my own post :
pretty sure the ATMEGA16U2 has lost its programming ..  
what hardware is needed to reflash it ?

never mind

-- was able to dig up the info / for the record

A) avrdude.exe / avrdude.config is not located where the doc say -- it is in:
    arduino-***/hardware/tools/avr/bin

B) the hexfile is buried pretty deep
    arduino-***/hardware/arduino/sam/firmwares/atmega16u2/Arduino-DUE-usbserial.hex

C) I used a Nano as a AVRISP which has the same pinouts as the UNO descibed in
    http://arduino.cc/en/Hacking/Upgrading16U2Due

D) the Nano would error out ("avrdude: stk500_getsync(): not in sync: resp=0x15") without the required a 120ohm resistor  between Vcc & reset
    http://laclefyoshi.blogspot.ca/2011/01/note-of-caution-for-arduino-isp.html

--- this was all to no avail - my Due still can not be programed via the USB Programming port
to program my Due requires a tenitive connection to the USB native port which resets after every upload (^#&$%&%!!!)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy