Pages: [1]   Go Down
Author Topic: Problems communicating IMU MPU9150 to Arduino Micro  (Read 625 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

I am having problems communicating the MPU9150 to the Arduino Micro. I am using a logic level converter as the Arduino runs at 5V while the sensor runs at 3.3V. I read in some places that I might not need it but I thought it's just better to have one in place.

Logic Level Converter - https://www.sparkfun.com/products/8745
MPU9150 IMU Sensor - https://www.sparkfun.com/products/11486
Arduino Micro - http://arduino.cc/en/Main/arduinoBoardMicro

Here are my connections:

ARDUINO <> Logic Level Converter <> MPU9150
5V <> HV <> N/A
3.3V <> LV <> N/A
GND <> GND (Both) <> N/A
A4 <> Chan1 Tx <> SDA
A5 <> Chan2 Tx <> SCL
GND <> N/A <> GND
3.3V <> N/A <> VCC

I also have two 4.7k pull up resistors on the A4 and A5 on the Arduino connected to 5V and two 10k pull up resistors on the SCL and SDA on the IMU connected to 3.3V.

I have NOT connected anything on the IMU INT or AD0 pins.

I am running a standard I2C scanner code found here: http://playground.arduino.cc/Main/I2cScanner

My Arduino is unable to talk to the IMU smiley-sad I also tried this config with a friends IMU (which was confirmed to work) and it did not work with that either.

Is there something I am missing here? Please advise.
Logged

Offline Offline
Edison Member
*
Karma: 58
Posts: 2078
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, something missing.

http://arduino.cc/en/reference/wire
The I2C pins are not on A4 and A5 (that is for the ATmega328p), but on digital pin 2 and 3.

The Micro is like the Leonardo.
http://arduino.cc/en/Hacking/PinMapping32u4
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That solved it. Thanks!!
Logged

Pages: [1]   Go Up
Jump to: