Pages: 1 [2]   Go Down
Author Topic: Arduino MEGA 1280 + Ethernet Shield (Não Funciona)  (Read 1665 times)
0 Members and 1 Guest are viewing this topic.
Portugal
Offline Offline
Edison Member
*
Karma: 27
Posts: 1414
Tomorrow I will know a BIT more than yesterday
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Para a placa funcionar necessita de lhe dares alimentaçao e a ligaçao via SPI(incluida na ficha ICSP).entao passa fios directos e nao encaixes a shield por cima do MEGA.Passei os olhos no esquema do oficial (esse deve ser parecido) e la tambem nao ligam o pino RX TX pois nao é necessario.Faz este teste liga com fio sem colocares a placa por cima.
Eu em tempos tive um problema semelhante, no meu caso nao conseguia fazer upload de nenhum skeetch com a placa encaixada.O motivo era que a ethernet shield tinha uma resistencia de Pull-Up também na linha de reset (pino 5 ICSP) e que fazia com que o micro não reseta-se e o bootloader entra-se em açao.
A minha solução foi remover a resistencia e ja passou a dar.O teu problema pode ser diferente ...
Nao sei se te poderá servir de alguma coisa mas tirei uma foto agora a minha shield onde assina-lo a resistência que removi.


* ethernet_.jpg (883.35 KB, 3264x2448 - viewed 20 times.)
Logged

Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B


Bom Princípio - RS
Offline Offline
Sr. Member
****
Karma: 0
Posts: 263
SOFTWARE DEVELOPER, HACKER, RASPBERRY/ARDUINO/QT ENTHUSIAST & METALLICA FAN
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Brigadão HugoPT, o seu shield também dava este problema de perder a conexão serial ao colocá-la no arduino ?
Logged

My Toys:
Raspberry Pi (Model B)
Arduino MEGA 1280: ( Shield LCD 16x2, Ethernet, RFID )
Freescale Kinetis KL25Z [/

Portugal
Offline Offline
Edison Member
*
Karma: 27
Posts: 1414
Tomorrow I will know a BIT more than yesterday
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bom isso não te sei confirmar pois quando usei a ethernet shield não usava a porta serie no meu código.
So tinha o problema no momento de fazer upload do sketch.Ja fizeste o ensaio com as ligações manuais sem encaixar a shield?
Logged

Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B


Offline Offline
Newbie
*
Karma: 1
Posts: 34
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Você comprou seu shield no DX.com?
comprei meu arduino e shield wizinet lá..
comprei o compativel com o mega, joguei o código lá. e thanran..
não conectou, ai eu fui e apertei o reset.
ai o computador reconheceu tranquilo smiley-grin
e não precisei fazer hack nenhum..
Logged

Pages: 1 [2]   Go Up
Jump to: