Pages: [1]   Go Down
Author Topic: getting avrdude error when uploading sketches  (Read 20055 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

whenever i try to upload a sketch, i get this error:

Code:
avrdude: error: buffered memory access not supported. maybe it isn't a butterfly/AVR109 but a AVR910 device?

i just got the Esplora and even the esplorablink wont work
Logged

US
Offline Offline
Full Member
***
Karma: 4
Posts: 182
Electronics are the new Legos
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ensure you follow the steps at http://arduino.cc/en/Guide/ArduinoEsplora to include using the latest non-1.5.x IDE version (1.0.5 as of today) and selecting Esplora as the target board in the IDE.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thanks! just a quick question, how do you do this? i cant get anything to work with the new drivers
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Esplora an Leonardo are programmable through USB port directly. They can also function as a human Interface device when connected. They seem prone to receive 2 com ports which makes it a little bit more difficult to target them on the correct serial port.

After several errors on a Windows Vista notebook I swapped to another usb connection port which solved the problem there. Give it some time as drivers may re-install themselves on the back ground.

Board type should be set correctly to Leonardo / Esplora. Programmer type is USBasp.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

I also encountered this error while uploading the Esplora Temperature Sensor example:

“Binary sketch size: 6,472 bytes (of a 28,672 byte maximum)
Found programmer: Id = "B«f"; type = “
Software Version = . ; Hardware Version = .
avrdude: error: buffered memory access not supported. Maybe it isn't a butterfly/AVR109 but a AVR910 device?”
 
What could the problem be and how can I correct this?
 
I also noticed that the Serial Monitor closes as soon as I start to upload the program.
How can I correct this?
 
Also I want to know does the board already have an inbuilt temperature sensor, or do I have to connect a physical temperature sensor for the program to work?
 
Thank you.
 
David.
Logged

US
Offline Offline
Full Member
***
Karma: 4
Posts: 182
Electronics are the new Legos
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Make sure in Programmer -> Tools you have the first one checked.  Make sure you have a good USB cable.
Logged

Pages: [1]   Go Up
Jump to: